Print Page | Close Window

[Solved] AirTrafficFx issues

Printed From: SimForums.com
Category: Flight One Software Forums
Forum Name: AirWrench - Air Traffic FX - GeoApr and FS Stall Effects
Forum Description: Forum for AirWrench, AirTraffic FX, GeoApr, and FS Stall Effects
URL: https://www.simforums.com/forums/forum_posts.asp?TID=62440
Printed Date: August-11-2020 at 3:45pm
Software Version: Web Wiz Forums 12.01 - http://www.webwizforums.com


Topic: [Solved] AirTrafficFx issues
Posted By: robert0606
Subject: [Solved] AirTrafficFx issues
Date Posted: March-03-2020 at 11:59pm
Hello I am experiencing two problems with this software.

When I "add formation to local air traffic queue", after they takeoff the last plane is always bugged. It doesn't stay in formation and the planes attitude jerks and twitches around.

When I "add formation with flight plan to enroute traffic" the planes don't appear on the radar or in the general area, but if I make a new view on them, I see they are stuck in a featureless void.

Contents of log file:

AirTrafficFX v4.28
Log file opened...
Windows 6.3
Wed Mar 04 06:50:33 2020 - Licensed version
Found 325 aircraft variations - 325 added to aircraft list
Start simconnect interface

Connected to Flight Simulator!
Open: Lockheed MartinĀ® Prepar3DĀ® v4 v4.5.13.32097
SimConnectVersion: 4.5.0.0
UID=1 Lat=-29.966708  Lon=30.948322  Alt=36.8  V=0.0  Heading=130.89
Distance to LAX=9227.4
Distance to JFK=7170.0



Replies:
Posted By: mudpond
Date Posted: March-04-2020 at 12:22pm
With respect to  "add formation to local air traffic queue" issue, this may be a performance issue.  Adding too many aircraft may overload the system.  Do you notice an effect on the frame rate?  Have you tried different numbers or types of aircraft in the formation?

With respect to "add formation with flight plan to enroute traffic", the added aircraft should appear in flight above the flight plan's departure location.  Try creating a simple airport to airport VFR flight plan using airports near your aircraft's starting location and using that flight plan for the formation.

If the problems persist, I will investigate further.


Posted By: robert0606
Date Posted: March-05-2020 at 12:26am
I play with locked 30 FPS, to look for performance issues I had to unlock the frameratre. Before adding planes: 177 FPS, after adding 36 planes: 139 FPS

The number of planes in the formation makes no difference, its always the last one that is buggy.

Your suggestion for testing enroute traffic is exactly how I have been doing it. I used joinfs to see if it would show where the planes were placed, it said 3854nm away from my location. I think there is a runway DB problem. If I click "update runway database" button and then "ok" button, the dialog closes and the runways are not updated.


Posted By: mudpond
Date Posted: March-05-2020 at 12:33am
Thanks for the feedback and extra info.  What airports are you using for your location and flight plans? 


Posted By: robert0606
Date Posted: March-05-2020 at 12:11pm
My plane at FADN, flight plan FADN to FAPM. I have tried other locations, no difference.


Posted By: mudpond
Date Posted: March-06-2020 at 11:07am
I've found the program works with flight plans in the northern hemisphere, but it is not handling flight plans in the southern hemisphere correctly and will need to be updated to fix the problem.

Investigating the "add formation to local air traffic queue" issue is next in the queue, and I'll post back when I've got a better handle on that one.



Posted By: mudpond
Date Posted: March-08-2020 at 10:20am
Both problems have been found and corrected.  An updated version of the program should be available to download in the near future.


Posted By: mudpond
Date Posted: March-08-2020 at 8:41pm
Version 4.29 is now live.  Use the 'Check for Updates' button on the About tab to download the update.



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.01 - http://www.webwizforums.com
Copyright ©2001-2018 Web Wiz Ltd. - https://www.webwiz.net