Print Page | Close Window

FAQ: Installation or Re-installing FEX

Printed From:
Category: Flight One Software Forums
Forum Name: Flight Environment Series
Forum Description: For all discussion related to Flight Environment.
Printed Date: December-10-2019 at 3:56am
Software Version: Web Wiz Forums 12.01 -

Topic: FAQ: Installation or Re-installing FEX
Posted By: ChrisNorris
Subject: FAQ: Installation or Re-installing FEX
Date Posted: May-31-2008 at 12:08pm

Many people from time to time have to face the onerous task of re-installing their operating system and therefore have to reinstall FEX. This FAQ summarizes the most common problems people have experienced either installing FEX for the first time or when reinstalling.

Common installation problems:

1. FEX appears to hang during installation: FEX carries out some pre-processing of texture files during the install process, at the time FEX was built a limitation of the installer package was that we could not update the progress bar whilst this was occuring. Therefore it can give the impression that the install has frozen or hung. The solution is to simply wait till the final dialog appears telling you FEX has installed succesfully.

2. Errors during installation: This is usually the result of either not having the .Net 2.0 runtime installed or the install is in-correctly working. The installer in many cases can detect whether you have .Net 2.0 installed however the detection code is not fall-proof for every computer. The solution is to download and install .Net 2.0 runtime from: -  and then run the FEX installer again following the required reboot.

3. FEX is installed but will not launch: This problem is again related to .Net 2.0 runtime. Please follow the steps in (2) and reinstall FEX after the runtime is installed.


4. FEX is asking me to register again: When re-installing FEX it will clear out your old settings and thereby show the registration screen once more. You do not have to enter your information again, simply click "Close" on the registration screen and you will see the normal "Login" screen, where you can enter your Username and password you originally registered with. If these have been forgotten you can recover these details from: -

5. I have re-installed FEX from the FEX_Installer.exe however it is reporting I do not have a valid Flight1 key: When completely reinstalling your operating system, you will need to install FEX from the original Flight1 Wrapper. There is a "Re-install" button on the Flight1 wrapper which will create the required license on your installation.


Posted By: Zeonblue
Date Posted: July-07-2008 at 9:47am


Ok I am having problems reinstalling, [XP,FSX with sp1 and Acceleration Pack,XP sp3]

When the words "original wrapper" is mentioned what is this refering to?

anyway I reinstalled windows and then FSX etc then FEX, but then I get the invalid key message and I dont see any "Reinstall Button".Confused

Thanks in advance.

Update: do I need to redownload the 669mb installer?

Ok ignore this post it was the installer I wanted, cheers.


Posted By: WebMaximus
Date Posted: July-16-2008 at 8:24pm

I have the same question with an error message saying I don't have a valid key after re-installing FEX after switching over from Vista 32-bit -> Vista 64-bit.

I do have the lic file, is there some way I can point that file out to FEX or do I need to do another re-install using the wrapper and if I do so what will then happen to the updates I've already applied (FEX_Patch_1042 & FEX_SHD) - do I need to re-install those too after using the wrapper?



Posted By: Zeonblue
Date Posted: July-16-2008 at 8:35pm

If you dont have the installer/wrapper, then re-download it.

When you install it and arrive at the payment part you will see in the bottom right of the payment screen a button that says "reinstall", click that and either use the lic file or the account option to start the reinstall.

If its a clean install then you will need to reinstall the Hi-Rez update again too

Posted By: WebMaximus
Date Posted: July-16-2008 at 9:57pm

OK, thanks I'll try that but as I said in my first post I have already installed everything - both the main program (FEX) + the patch + the SHD update and again...after pointing out the lic file after pressing the Reinstall button will that be enough or do I need to proceed once again with the installation and if I do...will I then have to install the patch + the SHD update once again?

Sorry if I'm stupid, just want to make sure how I should proceed to have a 100% good installation once I'm done.


Posted By: Zeonblue
Date Posted: July-17-2008 at 10:15am

I had the same trouble as you so I just downloaded it again and installed it as I said in the previous post.

if you cant get it to work then the only solution is to start at the begining.


Posted By: WebMaximus
Date Posted: July-17-2008 at 11:12am

Got everything to install and work just great by re-installing everything from scratch incl the patch and all seems good now, thanks for your help!


Posted By: Zeonblue
Date Posted: July-17-2008 at 11:13am
Happy to have been of assistance, cheers.

Posted By: fly1
Date Posted: July-18-2008 at 9:13am
Sorry i am also getting message "Invalid Licence Key"Have retrieved my original password and key but still no luck.
I think it may have something to do with the number of reinstallations i have had .
Would appreciate  your help on this.Regards fly1

Posted By: Steve Halpern
Date Posted: July-18-2008 at 9:26am

Redownload the product, and reinstall it with your key file and password, but NOT your FEX login and password, as this is different.

You can cancel the setup after the product unpacks if you only need the license part.


Posted By: fly1
Date Posted: July-18-2008 at 9:43am
Thanks for the reply Steve but i dont appear to have a Key file.
Have user name,password from credit card ,order no, and Cert Number but no Key file.Thanks fly1

Posted By: Zeonblue
Date Posted: July-18-2008 at 11:10am

You need the file with the extention "lic" then browse to its location so the software can verify the authenticity of it.

Posted By: fly1
Date Posted: July-18-2008 at 12:09pm
Thanks for the try Zeon but i do not have such a file.STEVE or CHRIS??

Posted By: Zeonblue
Date Posted: July-18-2008 at 12:17pm



Posted By: fly1
Date Posted: July-19-2008 at 10:47am
Hi Steve,Still having problem here.Have i run out of downloads?

Posted By: fly1
Date Posted: July-20-2008 at 9:40am
Hi Finally got it.Needed a new Key.Thanks guys for the great software.Cheers fly1

Posted By: devil
Date Posted: July-21-2008 at 5:34pm

Hi chris, maybe you can help me to solve this mess........i have installed FEX with SHD but after i installed also patch which was previously issued.....ClapClapConfusedConfused

Now every time I try to install a theme the reply is"the path specified in XMl does not exist...."and i cannot neither exit FEX

Now my question is do i Have to download again and reinstall Fex and SHD patch????How can i reactivate it?????

If so can you link me correct site to do it?????

 MAny Thanks for your help, is very urgent ..........

Posted By: Andrzej
Date Posted: January-24-2009 at 11:16am
Hi Chris,
I got a bit different problem at reinstallation of FEX. I was using FEX for some time, everything was Ok also after all upgrades. I have encountered problems with Leved 767 and ATR 72 recently. People on LEVEL D forum suggested that I should reinstall the plane etc. I figured out that I may take the opportunity to reinstall also FSX to a better than program files location (I am running Vista Ultimate 64bit). I have uninstalled all the addons, the fsx and started again the process. Everything was going smoothly - the FSX with sp1 and sp2, level d, atr, ultimate traffic etc and after I installed FEX i was stopped. It works, but at start up it questions me for user name and the password - kill me - I do not remember thatAngry. How to retrieve it or reset?

Thanks for help,

Posted By: katyp
Date Posted: January-24-2009 at 12:41pm

This - link is given by Chris in his first post on that thread


Posted By: Andrzej
Date Posted: January-25-2009 at 3:35am
Hi Katy,
Sorry for that, did not notice that...Got it back now.
Thank you very much.

Posted By: FLighT
Date Posted: February-11-2009 at 1:30pm

Well, my FEX install, which was only a few weeks old stopped functioning. If I try to open the program from the shortcut I get a Windows that states:

Flight Environment X has stopped working

Close the program, or

Debug the program

Neither of which does anything. I am on Vista64, no problems with any other program but this. I see the note at the top of this thread about installing (or reinstalling)the .nets. Are there different ones for 32 versus 64 bit windows? I uninstalled FEX and reinstalled from the F1 website and the setup went through without a hitch but it refuses to open for me. I've read every thread I could find using search but I'm not getting anywhere. I can't imagine why my .net would be screwed up. Other than install 1 addon plane recently there have been no other changes to my computer which is used for FSX only. And everything else sems to work fine: UTX, GEX included.


Posted By: harleyman
Date Posted: February-24-2009 at 6:30am
Did you ever get it going ????

Posted By: FLighT
Date Posted: February-24-2009 at 9:35am

Yes, but the only way was a complete reformat and reinstall of the OS, FSX and all addons. I left FEX for last, have turned System Restore back on temporarily before reinstalling so if FEX fails again I can roll back and go with XGraphics which I had on my old rig and never had any issues with. Close to 30 hours sitting at the computer. The .net reinstalls were not the solution as Vista would not allow it claiming they were already installed. My C++ was up to date as well.

So far FEX is working but I don't know why it failed the first time after working for a few weeks. 

The reason for the reinstall of everything was that in the FEX uninstall process the first time I hosed something big time in the registry and lost files, I couldn't relocate them, and so had to start over from scratch.


Posted By: harleyman
Date Posted: February-24-2009 at 10:41am

I think Vista comes with 3.5 runtime....


Thats real odd about the regestry deal..Onlything I know that can make programs drop out of sight and not work is an OC....... Like a voltage spike causing errors in the regestry..


But I'm sure there are others things too that will caus it..i just don't know what they are....LOL


Glad its going now..That bites for sure..I have done it literally dozens over the last 8 months..No more for a while I hope now...Clap

Posted By: FLighT
Date Posted: February-24-2009 at 11:18am


Posted By: oldwun
Date Posted: March-07-2009 at 12:19pm
My first post. My inital installation problem is strange.I have an incomplete main screen. The last quarter of the entire page is missing from top to bottom. Including the red cross at the top and the two action buttons at the bottom. All the buttons on the left side work. The incomplete page cannot be stretched and the bottom of the page is not complete for the last 3 buttons. I have no way of trying to download a replacement.

On Final Approach Low Fuel No Go Around.

Posted By: oldwun
Date Posted: September-08-2009 at 5:41pm
I have come to realize my inital post must be one of a kind . I have read the posts and that has helped. I have used it to Download FEX for my second installaton attempt. Prior to starting I deleted the inital download. The download went smoothly. When I opened the new program version 1.10.000 it was the same result as my original post details. It was the full frame containg only about a half of the main page cutting off vertically at v probably of the word versions.The Buttons Main down thru Help all are fucntonal. So are all the clickable pictures. The normal window boxes to close the program are not available. I use the task master. I found the error log . Error was: Value cannot be null. Parameter name:ptr Source:  System Delgate Getde Legate for FunctionPointer (Intptr,system)

On Final Approach Low Fuel No Go Around.

Posted By: Seadog
Date Posted: September-08-2009 at 6:41pm
Oldwun -

This result often happens to people who have changed the screen fonts to a larger font so they can read things more clearly. Many programs will display control panels that are cut off if you do not use the Normal Size (96 DPI) screen font. Such folks have generally changed it to the Large Size (120 DPI) font. In Windows XP (can't say about Vista), it is found by Right-clicking on the desktop and selecting Properties, which brings up the Display Properties box. Then select the right most Tab, Settings. Then look in the bottom right and click on Advanced. Then look in the first Tab that opens in the new box, General, and you will find the Display DPI setting, where you may make the choice. Hope that helps.

Posted By: oldwun
Date Posted: September-11-2009 at 1:08pm

Hi Seadog

 Your diagnosis,corrective action was brilliant. I sincerely thank you for a full screen with normal fuctioning controls.  Well Done!

On Final Approach Low Fuel No Go Around.

Posted By: Seadog
Date Posted: September-11-2009 at 4:03pm
Good news, Oldwun. Glad to hear you have full functional control again.

Your quest for help eluded earlier detection because it was not in its own, new thread. FAQ's are generally a place where the program developers list matters of common interest, but are rarely used for dialog. Sorry it took so long for anyone to see your request for help, but glad it ended well.

Posted By: MI_Rob
Date Posted: April-20-2012 at 12:30am
Originally posted by WebMaximus WebMaximus wrote:

II've already applied (FEX_Patch_1042 & FEX_SHD)

I just purchased FEX on DVD version.  I donwloaded a path off the FEX product page that is an update patch to v2.03.  What is the FEX_SHD patch and where can I download it.  I seen something in a message about an SHD Patch and Server. What is this SHD stuff?  Never heard of it.
Any info Appreciate.....Thumbs Up


Posted By: Goggle Eye
Date Posted: December-08-2013 at 4:26am
Please help

windows 7 64 Bit full retail version

When I check Start/Control Panel/Programs I do not see.Net 2.0 runtime installed.

Checked windows up date I do not see Net Frame Work 2.0 version.

Do see Net Frame work 4.5.1

Do I still need to install Net Frame Work 2.0?

I do not want to over write Net Frame Work 4.5.1 version or any windows up dates.

did Net Frame work 2.0 up dated to 4.5.1?

SP 1 comes on the windows install disk up dated to SP 2. The link for the down load includes SP 1.

I did not have any issues with the install. I have yet to figure out how to use FEX. FEX does not appear to be working I could be mistaken since I am not real familiar with FX Gold or FEX. I normaly fly real weather do I need to select custom weather instead of real weather?

Does FEX work in real weather when selected?

Did install the up dates and logged in down loaded all of the themes that's available. Read the PDF file instructions.    

Posted By: idahosurge
Date Posted: December-08-2013 at 8:09am
Google Eye,
See my post here" rel="nofollow -

STZ87 / 4770K @ 4.7GHz/4400MHz; TR SB-E x2; G.Skill Trident X 8GB 2400MHz @ 9-11-11-31-1T; Gigabyte GTX780 OC; OS SSD-840 Pro 256GB; FSX SSD-840 Pro 256GB; CS AX860i; Win7 Ult 64b; HAF-X

Posted By: Goggle Eye
Date Posted: December-11-2013 at 12:40am
Need some help with Flight Enviroment X for FSX

I always fly real weather In FSX. Will Enviroment X for FSX work in FSX Real weather environment?

If not then what is a good real weather software to run in FSX?

Am also having a installation issues.

I have to change the install directory from C/Programs (x86)

Then it ask me to change the directory again.

FSX Root directory is on G: Drive and nothing else.

when I try to run the up date it will not install If I select

G:FSX/Flight One Software/Flight Environment X/

Get a message saying directory missing and cannot install.

Do I need to install all of Flight Environment X to the G/Drive Root Directory?

Posted By: Goggle Eye
Date Posted: December-11-2013 at 1:12am
Will FSX Enviroment X for FSX work when you select FSX real weather?

Ok got the install figured out. Uninstalled, re booted to windows/ installed/Flight Enviroment X for FSX to the G Drive FSX/Root directory/
You cannot run the up-date if you open folders past Flight One Software.

Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.01 -
Copyright ©2001-2018 Web Wiz Ltd. -