SimForums.com Homepage
Forum Home Forum Home > Flight One Partner Forums > Opus Software
  New Posts New Posts RSS Feed - P3D v4.5, OpusFSI v6, and mode 5
  FAQ FAQ  Forum Search   Register Register  Login Login

P3D v4.5, OpusFSI v6, and mode 5

 Post Reply Post Reply
Author
Message
gjereza View Drop Down
Intermediate Group
Intermediate Group


Joined: February-23-2020
Location: California, USA
Points: 43
Post Options Post Options   Thanks (0) Thanks(0)   Quote gjereza Quote  Post ReplyReply Direct Link To This Post Topic: P3D v4.5, OpusFSI v6, and mode 5
    Posted: April-10-2022 at 4:01am
Hi,

I just noticed this now. My v6 of OpusFSI say that it is Mode 5. I'm assuming that's it's for P3D v5x?  But since I'm not using P3D v5, shouldn't the mode be something else?  Thank you.
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 15322
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: April-10-2022 at 4:47am
Make sure you are running the sim first, then the P3DSERVER program will be able to determine the P3D version (4.5 or 5.x ) from the v4 or v5 in the simulator's main window's title.

Also close then reopen the Spy window. You should see something like..

 SIM  Connected to Flight Simulator
 SIM  Prepar3D Version 4.5.14.34698 SimConnect Version 4.5
 SIM  Prepar3D SDK Version 4.5.14.34698
 SIM  Air Folder = RealAir Legacy V2
 SIM  8 Matching Camera VC/2D/External Views For Aircraft
 PDK  Connected to OpusPDK Interface (6.16.00)
 PDK  OpusPDK View Mode = Virtual Cockpit
 PDK  OpusPDK Responding OK
 MET  Dynamic Weather Not Updated

displayed.

Of course also make sure you are running the latest OpusFSI v6 (version 6.20.3) release.

Stephen
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 15322
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: April-10-2022 at 4:52am
Also make sure you are not supplying a V5 argument to the P3DSERVER.EXE program. Just run the program with no additional arguments and let P3DSERVER determine the sim mode via the running Prepar3D program.

Stephen
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 15322
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: April-10-2022 at 4:54am
Update...

The sim version can also be obtained via the SimConnect interface, again the sim needs to be running before that can be determined. Best close and reopen Spy and check what is displayed in the OpusFSI Spy window (see above).

Stephen
Back to Top
gjereza View Drop Down
Intermediate Group
Intermediate Group


Joined: February-23-2020
Location: California, USA
Points: 43
Post Options Post Options   Thanks (0) Thanks(0)   Quote gjereza Quote  Post ReplyReply Direct Link To This Post Posted: April-10-2022 at 1:17pm
I'm launching OpusFSI v6 from the exe.xml file in C:\ProgramData...

Is there anything wrong with running OpusFSI in th exe.xml file below? It's working. But, I'm seeing that "Mode 5". Should I be seeing the "Mode 5"? Or, can I simply ignore it.

I am running v6.20.3. I ran a test by running P3DSERVER.EXE by itself outside of the exe.xml file without any parameters but I'm still getting the "Mode 5" on the main screen.

I don't know if this is relevant but I also have the Opus_v5 version installed in the same PC for when I run FSX Steam. Thank you.

---
<SimBase.Document Type="AceXML" version="3,0" id="exe">
    <Descr>AceXML Document</Descr>
    <Filename>exe.xml</Filename>
<Launch.Addon>
  <Name>OpusFSI_v6 Flight Simulator Interface Server</Name>
  <Disabled>false</Disabled>
  <Path>c:\OpusFSI_v6\P3DSERVER.EXE</Path>
<CommandLine>DELAY2000 P3D45</CommandLine>
</Launch.Addon>
</SimBase.Document>
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 15322
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: April-10-2022 at 1:23pm
The exe start should work ok. You could try shutting OpusFSI down and restarting manually without using any program arguments. OpusFSI should see V4 is running and auto select that mode.

You should be seeing mode 4. Change the P3D45 argument to just V4 and see what you get then.

I will also try your exact same startup tomorrow and report if I find something. Don’t forget to close then reopen the OpusFSI Spy window. Check what it reports in Spy after reopening as it may then have noted the correct V4 P3D mode.

Stephen
Back to Top
gjereza View Drop Down
Intermediate Group
Intermediate Group


Joined: February-23-2020
Location: California, USA
Points: 43
Post Options Post Options   Thanks (0) Thanks(0)   Quote gjereza Quote  Post ReplyReply Direct Link To This Post Posted: April-10-2022 at 1:26pm
Oppps... Looks like you replied while I was editing my post. Please check the edited post above yours. Thanks.
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 15322
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: April-10-2022 at 1:32pm
No problem with OpusFSI v5 installed on same machine.

You should see Mode 4 or Mode 5 when you are running P3Dv4 and P3Dv5 respectively. It does matter so should be sorted.

If you run P3D in Windowed mode, what does it report with its own main window (form) caption. does it include a v4 or v5 identity?

What does Spy report when you reopen it, what version of P3D and SDK does it report finding?

Stephen
Back to Top
gjereza View Drop Down
Intermediate Group
Intermediate Group


Joined: February-23-2020
Location: California, USA
Points: 43
Post Options Post Options   Thanks (0) Thanks(0)   Quote gjereza Quote  Post ReplyReply Direct Link To This Post Posted: April-10-2022 at 2:02pm
Sorry for the delay. I tried posting but I was getting a Server 500 error replying to your post. I'm not sure why.  I think it might have been because of the file size limitation. I'll reduced the file size.

Thank you.
---






Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 15322
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: April-10-2022 at 2:07pm
Thanks. Yes I believe there’s a limit to image sizes within the forum.

Looks like the software is recognising the P3D v4.5 sim so it could be a case of simply not updating or modifying the OpusFSI main forms caption during your startup process. Possibly down to the 2s start delay or something else.

I will investigate tomorrow and post an update. Nothing to worry about for now as when it sees P3D version 4.5 is active it changes its internal mode to 4.

Stephen
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 15322
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: April-10-2022 at 2:08pm
I did see your image for a short while. Long enough to see that Spy reported P3D version 4.5 in use. No need to post the image again.

Stephen
Back to Top
gjereza View Drop Down
Intermediate Group
Intermediate Group


Joined: February-23-2020
Location: California, USA
Points: 43
Post Options Post Options   Thanks (0) Thanks(0)   Quote gjereza Quote  Post ReplyReply Direct Link To This Post Posted: April-10-2022 at 2:20pm
Thank you. I have a reduced and non-blurry image size with the Add-ons sub-menu shown also. Let me know if you need more info, and I'll post it.
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 15322
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: April-10-2022 at 2:22pm
Should be enough info now. I’ll report back tomorrow after recreating your setup but it’s most likely just the caption that’s not being updated after seeing it’s connected to v4.5 sim and changing to mode 4.

Regards
Stephen
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 15322
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: April-11-2022 at 3:17am
I have not been able to recreate your problem yet.

You reported, "I'm launching OpusFSI v6 from the exe.xml file in C:\ProgramData..."

Can you please check your...

C:\Users\<user_name>\AppData\Roaming\Lockheed Martin\Prepar3D v4

folder and see if you have another EXE.XML file defined there. If you do then delete or rename it as P3D could be using that one to start OpusFSI. It's a strange quirk of P3D that it can use DLL and EXE XML files from either it's c:\..\AppData or c:\ProgramData folders.

Stephen
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 15322
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: April-11-2022 at 4:39am
I have posted a new release update, OpusFSI Version 6.20.4, that updates the displayed caption after receiving a version notification via SimConnect.

Don't forget to check to see if you have multiple EXE.XML files defined in your c:\..\AppData or c:\ProgramData folders as this will only cause problems in the future.

Stephen Smile
Back to Top
gjereza View Drop Down
Intermediate Group
Intermediate Group


Joined: February-23-2020
Location: California, USA
Points: 43
Post Options Post Options   Thanks (0) Thanks(0)   Quote gjereza Quote  Post ReplyReply Direct Link To This Post Posted: April-11-2022 at 8:58am
Thanks for the quick fix Stephen!

---



Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 15322
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: April-11-2022 at 9:00am
Pleased to hear it worked, thanks for the feedback.

Best regards
Stephen
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.188 seconds.