SimForums.com Homepage
Forum Home Forum Home > Flight One Partner Forums > Opus Software
  New Posts New Posts RSS Feed - No weather on CLIENT
  FAQ FAQ  Forum Search   Register Register  Login Login

No weather on CLIENT

 Post Reply Post Reply
Author
Message
Lorenbar View Drop Down
New Member
New Member


Joined: June-10-2019
Location: FRANCE
Points: 14
Post Options Post Options   Thanks (0) Thanks(0)   Quote Lorenbar Quote  Post ReplyReply Direct Link To This Post Topic: No weather on CLIENT
    Posted: September-02-2019 at 12:32pm
Hello Stephen,
After fully cleaning my 3 PCs, I reinstalled P3D v4 and version 5.28. (there is nothing else installed)
Everything works fine except the weather report on my 2 PC client? ... The weather loads well on the server, but nothing on my 2 PC Client, the weather does not change and, of course, there is nothing on the LWA Map.
I checked and rechecked all my file shares.
It looks like I have an error message "link 3 Exception Received From Simulator - Exception : 20"
Do you have an idea ?
Thanks
Laurent

Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 13870
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: September-02-2019 at 12:41pm
Are you starting the clients using the FSICLIENT.EXE start up program with the P3D argument.

Do not run P3DCLIENT.EXE directly as the above needs to prepare the required DotNet 4 SimConnect library.

Stephen
Back to Top
Lorenbar View Drop Down
New Member
New Member


Joined: June-10-2019
Location: FRANCE
Points: 14
Post Options Post Options   Thanks (0) Thanks(0)   Quote Lorenbar Quote  Post ReplyReply Direct Link To This Post Posted: September-02-2019 at 1:08pm
Stephen,

Yes, I use FSICLIENT.EXE to start. Target of my shortcut : "C:\OpusFSI_v5\FSICLIENT.EXE"

What do you mean "with the P3D argument" ?

I don't run P3DCLIENT.EXE, only FSICLIENT.EXE

Laurent 
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 13870
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: September-02-2019 at 1:14pm
Thanks. The fsiclient program will default to P3Dv4 so all should be well.

I will check the SimConnect error. You should check your SimConnect and also make sure you have set the sharing and permissions on your D drive and the sims install folder.

For weather to be displayed on the clients. The clients must be able to access the generated WTB file on your server (sharing and permissions needed here to), then copy that file into the sims Weather folder, finally issue a weather theme load command via SimConnect.

This is all triggered when the server sends a clock sync and weather update commands to the clients via the network links.

Stephen
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 13870
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: September-02-2019 at 1:16pm
Try also changing the servers IP Address to the servers Computer Name within the clients Configuration.

Just in case the generated WTB file cannot be accessed using the IP Address in the path name.

Stephen
Back to Top
Lorenbar View Drop Down
New Member
New Member


Joined: June-10-2019
Location: FRANCE
Points: 14
Post Options Post Options   Thanks (0) Thanks(0)   Quote Lorenbar Quote  Post ReplyReply Direct Link To This Post Posted: September-02-2019 at 1:44pm
Stephen,
I can't share D drive... But all necessary files are shared.
Listed below :
C:\OpusFSI_v5
C:\ProgramData\Lockheed Martin\Prepar3D v4
C:\Users\Laurent\AppData\Local\Lockheed Martin\Prepar3D v4
C:\Users\Laurent\AppData\Roaming\Lockheed Martin\Prepar3D v4
C:\Users\Laurent\Documents\Prepar3D v4 Add-ons
C:\Users\Laurent\Documents\Prepar3D v4 Files
D:\Lockheed Martin\Prepar3D v4

I also changed the Servers IP Address by the Servers Computer Name, no change apart from many lag...

How i do for check SimConnect ?
I've version 10.0.61259.0 installed.

Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 13870
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: September-02-2019 at 1:50pm
why can’t you share the D drive ?

You should check that the OpusWeather.WTB file is being transferred from the server into the client sims Weather or Themes folder. Not sure which folder it is, I think the former.

Do you have a Weather or Themes sub-folder within the sims install folder.

If not create the folder as that’s where the WTB theme files must be copied into so that the sim can load the weather theme (opus weather).

Stephen
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 13870
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: September-02-2019 at 1:52pm
Check and make sure the Opus Weather WTB File is being copied first.

If the WTB file is not in the client sims Weather sub-folder then no weather can be loaded.

Stephen
Back to Top
Lorenbar View Drop Down
New Member
New Member


Joined: June-10-2019
Location: FRANCE
Points: 14
Post Options Post Options   Thanks (0) Thanks(0)   Quote Lorenbar Quote  Post ReplyReply Direct Link To This Post Posted: September-02-2019 at 2:22pm
Stephen,

For the D drive, the share box is grayed out...
This has always been so since i've version 4 of opus.
But the subfolders are well shared ! (on each Client and on Server)

I'va a folder on server and on client :
D:\Lockheed Martin\Prepar3D v4\Weather\themes
On the server, I've :
OpusWeather.wt
OpusWeather.WTB

But on each client, i don't have this 2 files ...

I've the impression that the server can't send these 2 files to the Clients ...
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 13870
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: September-02-2019 at 2:29pm
Then that’s the reason you don’t have any weather changes.

The clients must be able to access the WTB file on the server.
The client must be able to copy this file into its own sims Weather Themes folder.
Then after the client issues the weather load via SimConnect the WTB file can be loaded by the sim.

No file copied = No Weather loaded

Hence the need to share the drives on the server and clients.
Permissions must also be granted Full Access for Everyone.
Any drive should be able to be shared.
Are you an Administrator?
You may need to change ownership of a drive.

Stephen
Back to Top
Lorenbar View Drop Down
New Member
New Member


Joined: June-10-2019
Location: FRANCE
Points: 14
Post Options Post Options   Thanks (0) Thanks(0)   Quote Lorenbar Quote  Post ReplyReply Direct Link To This Post Posted: September-02-2019 at 2:42pm
Ok Stephen,

I will start again quietly and I will tell you what it is.

I'll be back as soon as it works! Smile

Thank you very much for your responsiveness and your time to respond !

Laurent

Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 13870
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: September-02-2019 at 2:45pm
Good luck. You should see the Clock Sync and Weather Update messages in Spy (Show Data and Details). That’s the message from the server telling the client that a new weather WTB file has been generated and needs to be copied and loaded.

The client copies direct from the server into the sims folder before telling the sim to load it.

Regards
Stephen
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 13870
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: September-02-2019 at 2:47pm
Check to see if you can access the WTB file via Windows Explorer as well. Not the same as the software doing it but it may give some guidance.

Stephen 
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.01
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.125 seconds.