SimForums.com Homepage
Forum Home Forum Home > Flight One Partner Forums > EZdok Software > EZdok Beta Forum
  New Posts New Posts RSS Feed - EZCA v3 talk about !
  FAQ FAQ  Forum Search   Register Register  Login Login

EZCA v3 talk about !

 Post Reply Post Reply Page  <1 3456>
Author
Message
Blue1 View Drop Down
New Member
New Member


Joined: October-23-2006
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote Blue1 Quote  Post ReplyReply Direct Link To This Post Posted: March-13-2019 at 10:31am
Hi,

I notice too I got the same for me...but it's working anyway.


Back to Top
MikeFlight View Drop Down
New Member
New Member


Joined: March-29-2015
Points: 19
Post Options Post Options   Thanks (0) Thanks(0)   Quote MikeFlight Quote  Post ReplyReply Direct Link To This Post Posted: March-13-2019 at 10:52am
The same by me at first. After I did the update again, everything was okay again.
Michael
Back to Top
cavaricooper View Drop Down
Intermediate Group
Intermediate Group


Joined: December-29-2013
Location: Tampa, FL
Points: 96
Post Options Post Options   Thanks (0) Thanks(0)   Quote cavaricooper Quote  Post ReplyReply Direct Link To This Post Posted: March-14-2019 at 9:02pm
Am I the only one having issues with the SPOT view?  I do not have a Coolie Hat, but the mouse middle button worked fine for my needs in v2.  There is absolutely no movement for me in SPOT in v3.  If it is indeed only me, I am happy to try a full reinstall... I just want to make sure.

TIA!

C
Back to Top
Nickbe View Drop Down
Senior Member
Senior Member


Joined: May-06-2017
Location: Russia
Points: 1005
Post Options Post Options   Thanks (0) Thanks(0)   Quote Nickbe Quote  Post ReplyReply Direct Link To This Post Posted: March-15-2019 at 3:31am
Originally posted by jodle jodle wrote:

Configuration tool looks like this:
 


Hi!
Please download build 62 again and install. You downloaded the wrong version.

https://www.simforums.com/forums/get_last_post.asp?TID=61142&ID=43539.1449305556
Nick B.
Ezdok Software
Back to Top
cavaricooper View Drop Down
Intermediate Group
Intermediate Group


Joined: December-29-2013
Location: Tampa, FL
Points: 96
Post Options Post Options   Thanks (0) Thanks(0)   Quote cavaricooper Quote  Post ReplyReply Direct Link To This Post Posted: March-15-2019 at 8:37am
Marniftarr and Nick-

I sent a video showing my issue- please review and advise.

Ta- C
Back to Top
BobP View Drop Down
Senior Member
Senior Member


Joined: February-20-2003
Points: 122
Post Options Post Options   Thanks (0) Thanks(0)   Quote BobP Quote  Post ReplyReply Direct Link To This Post Posted: March-16-2019 at 8:28am
Hi everyone,

Is there a basic guide for installing with V2 installed? I.E. Uninstall V2? Leave it? Thank you!

Bob
Back to Top
Nickbe View Drop Down
Senior Member
Senior Member


Joined: May-06-2017
Location: Russia
Points: 1005
Post Options Post Options   Thanks (0) Thanks(0)   Quote Nickbe Quote  Post ReplyReply Direct Link To This Post Posted: March-16-2019 at 8:28am
Originally posted by cavaricooper cavaricooper wrote:

Marniftarr and Nick-

I sent a video showing my issue- please review and advise.

Ta- C


Carl, hi!
I watched the videos. Something's not working right. It should work differently.
Now on the weekend both Marniftarr and I are far away from computers.
Since the beginning of the week we will try to find out what the problem is.
Check again SPACEBAR settings in the simulator.
Nick B.
Ezdok Software
Back to Top
Nickbe View Drop Down
Senior Member
Senior Member


Joined: May-06-2017
Location: Russia
Points: 1005
Post Options Post Options   Thanks (0) Thanks(0)   Quote Nickbe Quote  Post ReplyReply Direct Link To This Post Posted: March-16-2019 at 8:33am
Originally posted by BobP BobP wrote:

Hi everyone,

Is there a basic guide for installing with V2 installed? I.E. Uninstall V2? Leave it? Thank you!

Bob


Bob, hi!
Ezca versions 3 and 2 do not overlap. If you do not remove EZCA2, EZCA3 will install and work normally. And will be able to transfer presets from version 2. Version 2 can be removed at any time later. Maybe something will go wrong with version 3 and you will need to temporarily revert to version 2, then you can not delete it yet.
Nick B.
Ezdok Software
Back to Top
BobP View Drop Down
Senior Member
Senior Member


Joined: February-20-2003
Points: 122
Post Options Post Options   Thanks (0) Thanks(0)   Quote BobP Quote  Post ReplyReply Direct Link To This Post Posted: March-16-2019 at 8:38am
Perfect, thanks Nick!

Bob
Back to Top
RRVyper View Drop Down
Senior Member
Senior Member


Joined: July-21-2017
Location: Canada
Points: 683
Post Options Post Options   Thanks (0) Thanks(0)   Quote RRVyper Quote  Post ReplyReply Direct Link To This Post Posted: March-16-2019 at 10:45am
Originally posted by cavaricooper cavaricooper wrote:

Am I the only one having issues with the SPOT view?  I do not have a Coolie Hat, but the mouse middle button worked fine for my needs in v2.  There is absolutely no movement for me in SPOT in v3.  If it is indeed only me, I am happy to try a full reinstall... I just want to make sure.

TIA!

C
Carl, have you tried resetting your keyboard/joystick assignments to default? You can try backing up the Standard.xml file located in the "C:\Users\<username>\AppData\Roaming\Lockheed Martin\Prepar3D v4\Controls" folder. Then, delete the Standard.xml file, run P3D (it will rebuild the file) and load the default scenario. At this point EZCA will not work correctly due to the conflicting key assignments. Shutdown P3D (wait 30 secs or until the Prepar3D.exe process has terminated) and then run the EZCA Config Tool. Finally, launch P3D again and see how things are. NOTE: this will remove any custom keyboard/joystick commands but if it's working better, just redo your assignments. Otherwise, restore the backed up Standard.xml file. Also, you don't need to delete the Standard.xmlx file.

Randy
Back to Top
simperfi View Drop Down
Senior Member
Senior Member


Joined: January-11-2015
Location: GB
Points: 2791
Post Options Post Options   Thanks (0) Thanks(0)   Quote simperfi Quote  Post ReplyReply Direct Link To This Post Posted: March-16-2019 at 10:50am
Originally posted by cavaricooper cavaricooper wrote:

Am I the only one having issues with the SPOT view?  I do not have a Coolie Hat, but the mouse middle button worked fine for my needs in v2.  There is absolutely no movement for me in SPOT in v3.  If it is indeed only me, I am happy to try a full reinstall... I just want to make sure.
TIA!
C
 

I use FSUIPC5(registered version) with P3d v4.4 

I disable all controllers in Prepar3d v4  
My controllers use FSUIPC5

In order to use ezdok  emulate MMB with the spot view I had to activate the Mouse look option 
within FSUIPC5  -
if I uncheck this option - No mouse panning 

image 1 

here are my ezdok Map of assignments settings
(I used HotkeySelect=10 but any free HotkeySelect can be assigned)

images 2,3

video confirmation - spot view - space bar and mouse movement -(my mouse MMB is not used)
Kevin
Back to Top
cavaricooper View Drop Down
Intermediate Group
Intermediate Group


Joined: December-29-2013
Location: Tampa, FL
Points: 96
Post Options Post Options   Thanks (0) Thanks(0)   Quote cavaricooper Quote  Post ReplyReply Direct Link To This Post Posted: March-16-2019 at 11:40am
FIRST- THANK-YOU so much for all your efforts!  They are greatly appreciated.

I have deleted the default.xml twice now.  I have also entered all assignments as per Marniftarr's update postings. My issue is that to get SPOT to work I have to use FSUIPC MM under Misc. as posted above.  That bit then works fine.  What gets buggered is my VC.  As long as I do not touch my mouse all is well.  As soon as I do, the view goes nuts.  Moving with every mouse movement.  The only way to fix that bit, it to unselect Mousewheel mouse look in FSUIPC.

Then my VC is fine, but my SPOT does not move, and all I get is a cross pointer that does move.

Sorry, if all this sounds a bit frustrated... working through.

Ta- C
Back to Top
BobP View Drop Down
Senior Member
Senior Member


Joined: February-20-2003
Points: 122
Post Options Post Options   Thanks (0) Thanks(0)   Quote BobP Quote  Post ReplyReply Direct Link To This Post Posted: March-16-2019 at 1:14pm
I installed EZCA V3 and it delivers a modern UI plus the move from V2 was smooth without any issues. I've tinkered with a a couple settings and competed a flight in the A2A Skylane which was without issues and FUN! I need to read the manual before digging further.

Congratulation on making a significant improvement in purpose and use while keeping the main features and familiarity of V2. I doubt that was a small task. :)

Bob
Back to Top
simperfi View Drop Down
Senior Member
Senior Member


Joined: January-11-2015
Location: GB
Points: 2791
Post Options Post Options   Thanks (0) Thanks(0)   Quote simperfi Quote  Post ReplyReply Direct Link To This Post Posted: March-16-2019 at 1:17pm
Originally posted by cavaricooper cavaricooper wrote:

FIRST- THANK-YOU so much for all your efforts!  They are greatly appreciated.

I have deleted the default.xml twice now.  I have also entered all assignments as per Marniftarr's update postings. My issue is that to get SPOT to work I have to use FSUIPC MM under Misc. as posted above.  That bit then works fine.  What gets buggered is my VC.  As long as I do not touch my mouse all is well.  As soon as I do, the view goes nuts.  Moving with every mouse movement.  The only way to fix that bit, it to unselect Mousewheel mouse look in FSUIPC.

Then my VC is fine, but my SPOT does not move, and all I get is a cross pointer that does move.

Sorry, if all this sounds a bit frustrated... working through.

Ta- C


I have been able to replicate the VC view flickering when spot view is setup
it was an entry in the FSUIPC5.ini file in the prepar3d modules folder that caused my flickering = a conflict was occurring with the [space] key set to emulate MMB

specifically this entry in the [general section]

UseMidMouseBtn=yes

I changed it to

UseMidMouseBtn=no

restarted the sim ======= no more flickering in the VC when moving the mouse


it was still necessary to check the box for Mouse Look, it appears that using MMB is turned on automatically if the mouse look option is active




Kevin
Back to Top
cavaricooper View Drop Down
Intermediate Group
Intermediate Group


Joined: December-29-2013
Location: Tampa, FL
Points: 96
Post Options Post Options   Thanks (0) Thanks(0)   Quote cavaricooper Quote  Post ReplyReply Direct Link To This Post Posted: March-16-2019 at 1:18pm
Originally posted by BobP BobP wrote:

I installed EZCA V3 and it delivers a modern UI plus the move from V2 was smooth without any issues. I've tinkered with a a couple settings and competed a flight in the A2A Skylane which was without issues and FUN! I need to read the manual before digging further.

Congratulation on making a significant improvement in purpose and use while keeping the main features and familiarity of V2. I doubt that was a small task. :)

Bob


C
Back to Top
cavaricooper View Drop Down
Intermediate Group
Intermediate Group


Joined: December-29-2013
Location: Tampa, FL
Points: 96
Post Options Post Options   Thanks (0) Thanks(0)   Quote cavaricooper Quote  Post ReplyReply Direct Link To This Post Posted: March-16-2019 at 1:26pm
Originally posted by simperfi simperfi wrote:

 

I have been able to replicate the VC view flickering when spot view is setup
it was an entry in the FSUIPC5.ini file in the prepar3d modules folder that caused my flickering = a conflict was occurring with the [space] key set to emulate MMB

specifically this entry in the [general section]

UseMidMouseBtn=yes

I changed it to

UseMidMouseBtn=no

restarted the sim ======= no more flickering in the VC when moving the mouse


it was still necessary to check the box for Mouse Look, it appears that using MMB is turned on automatically if the mouse look option is active



YOU SIR, ARE A GENIUS!  This fixed my issue, and I AM MOST GRATEFUL!!

I hope that your post will assist others who are having similar issues.  I appreciate your counsel and agree with the thought that v3 is indeed a significant step forward.

Again, thanks!

C

Back to Top
simperfi View Drop Down
Senior Member
Senior Member


Joined: January-11-2015
Location: GB
Points: 2791
Post Options Post Options   Thanks (0) Thanks(0)   Quote simperfi Quote  Post ReplyReply Direct Link To This Post Posted: March-17-2019 at 4:29pm
I just installed the fslabs aircraft and potentially avoided view issues and HotkeySelect conflicts by amending the 3 hotkeyselect entries in the FSLabs .config folders to disable them — not delete them —

the ezconfig tool will not remove/disable these entries from the Simobjects aircraft.cfg files because HotkeySelect= 2 3 & 4 are not ezdok conflicts but I want to use 2 3 & 4 myself

I also added MenuHidden=yes to the external views as I don't want them on the p3d view menu listing

ezdok map of assignments cannot alter the .config files - it has to be done manually I used
//HotkeySelect=2
//HotkeySelect=3
//HotkeySelect=4

this results in the SimObjects aircraft.cfg files being rebuilt with disabled hotkeySelect plus MenuHidden entries




there are 4 folders containing the aircraft.cfg file to be amended



then ran the sim —
so far the aircraft views load to the ezca3 VC cam on sim startup and switching from outside to vc has no problems
Kevin
Back to Top
debbie1 View Drop Down
New Member
New Member


Joined: February-04-2019
Location: US
Points: 38
Post Options Post Options   Thanks (0) Thanks(0)   Quote debbie1 Quote  Post ReplyReply Direct Link To This Post Posted: March-18-2019 at 3:44pm
HELP!!  I'm getting an "Critical Error" Message in RED when EZCA3 starts up. I have the latest build. Should I reinstall, or rebuild the DB?  This is very frustrating.  Fix does nothing. After completely uninstalling, removing all folders and registry entries, starting EXCA3 from scratch. Got Error again, but this time the fix button worked. Now getting sim connect delay messages. ???

Back to Top
simperfi View Drop Down
Senior Member
Senior Member


Joined: January-11-2015
Location: GB
Points: 2791
Post Options Post Options   Thanks (0) Thanks(0)   Quote simperfi Quote  Post ReplyReply Direct Link To This Post Posted: March-18-2019 at 4:01pm
Originally posted by debbie1 debbie1 wrote:

HELP!!  I'm getting an "Critical Error" Message in RED when EZCA3 starts up. I have the latest build. Should I reinstall, or rebuild the DB?  This is very frustrating.  Fix does nothing. After completely uninstalling, removing all folders and registry entries, starting EXCA3 from scratch. Got Error again, but this time the fix button worked. Now getting sim connect delay messages. ???




easy to replicate

map of assignments -- shows listed in HotkeySelect mapping -that F9 F10 F11 and F12 are still assigned in sim
remove F9 key assignment in sim controls -- view camera (select) 1 --

it is conflicting with an assignment in ezca3 vc cam views section

when you press fix button -- wait a few seconds -
apply changes -- should appear --
click on it and ezdok/sim will close in order to complete the fix
or
just go into sim controls and remove the F9 assignment then restart ezdok
using - file - restart

Suggest you remove all 4 F key assignments from sim controls
Kevin
Back to Top
cavaricooper View Drop Down
Intermediate Group
Intermediate Group


Joined: December-29-2013
Location: Tampa, FL
Points: 96
Post Options Post Options   Thanks (0) Thanks(0)   Quote cavaricooper Quote  Post ReplyReply Direct Link To This Post Posted: March-20-2019 at 2:40pm
Kevin-

Have you noticed that each time you press the MMB in SPOT the view reverts to the tail view initial position? My mouse is in cramped quarters and somthimes I have to release and re-press to get the rotation and zoom I want. That is when it resets. This is new, and I am not sure if there is still some interaction between EZDOK and FSUIPC for mouse view control.

Haven’t heard anything from Marniftarr or Nick, so hopefully they are Beavering away and will have a new build that fixes these issues for us, soon.

Again, I’m obliged- C
Back to Top
RRVyper View Drop Down
Senior Member
Senior Member


Joined: July-21-2017
Location: Canada
Points: 683
Post Options Post Options   Thanks (0) Thanks(0)   Quote RRVyper Quote  Post ReplyReply Direct Link To This Post Posted: March-20-2019 at 5:22pm
Carl,
This is not what I experience. When I switch to SPOT view, sometimes it starts at the rear (seems to depend on what camera I was using last - VC or Outside). When I press the MMB I can pan clockwise or counterclockwise to the nose, and above or below. No options are checked in FSUIPC for Mousewheel. Also this is with Active Zoom enabled or not. But, subsequent presses of the MMB do no reset it to rear.

Randy
Back to Top
simperfi View Drop Down
Senior Member
Senior Member


Joined: January-11-2015
Location: GB
Points: 2791
Post Options Post Options   Thanks (0) Thanks(0)   Quote simperfi Quote  Post ReplyReply Direct Link To This Post Posted: March-20-2019 at 6:33pm

just to clarify;

my post relates to users of Fsuipc5 who like me DISABLE controllers in P3d and use Fsuipc to send axis assignments to the sim

mouse look in FSuipc is ONLY required under such a setup 

to my knowledge Fsuipc does norhing in terms of mouselook that affects ezdok or the Spot view camera location - to test this i disabled FSuipc and used p3d controlls instead 

as randy points out the camera view for spot always starts at the tail of the selected aircraft on first use. then it returns to the position last used.

i suspect this is hard coded into the sim code but I cannot confirm it


Kevin
Back to Top
cavaricooper View Drop Down
Intermediate Group
Intermediate Group


Joined: December-29-2013
Location: Tampa, FL
Points: 96
Post Options Post Options   Thanks (0) Thanks(0)   Quote cavaricooper Quote  Post ReplyReply Direct Link To This Post Posted: March-20-2019 at 7:52pm
Randy & Kevin-

Again, thank-you both for researching and responding.

I have to use the FSUIPC Mouse Look (for MMB) tick box because like Kevin all my controls are disabled in P3D.

I just re-checked and there is a distinct move to the rear tail position any time the MMB is pressed.  As long as I hold it down, I can move around the aircraft and zoom and all is good.  As soon as I lift the MMB (because I ran out of room and have to move the mouse to get more rotation) and then press the MMB to pick up in the rotation, where I left off, the view resets to the rear.

I have tried this going to SPOT from VC and from Outside Cameras and it makes no difference re. the behavior.

We have heard nothing from the team, so I am hoping that there will be an update that resolves these issues and others discussed.  I am very pleased with the progress on v3 so far, and it just needs some tweaking to become the product it can fully be.

Optimistically hopeful- C
Back to Top
RRVyper View Drop Down
Senior Member
Senior Member


Joined: July-21-2017
Location: Canada
Points: 683
Post Options Post Options   Thanks (0) Thanks(0)   Quote RRVyper Quote  Post ReplyReply Direct Link To This Post Posted: March-20-2019 at 8:56pm
I did a bit more testing. With controls disabled (via Options/Other) I lose the ability to pan with the mouse in SPOT view. The cross (+) shows up when I press the MMB but the view does not pan when I move the mouse (with the MMB held down). If I then enable mouselook in FSUIPC, it works as it should and does not reset to the rear with each MMB press. However, if I have a key assigned to emulate the MMB, when I use that (e.g. SPACE) it does reset to the rear (in SPOT view) whenever I press the key! For you, Carl, pressing your MMB is like me using an emulated MMB, whereas my MMB works fine. Removing the emulate assignment does not affect my MMB operation, and as expected, the SPACE no longer emulates the MMB. My mouse is a Logitech G502. I am not using any macros and have no keyboard combos assigned to any mouse buttons.

Randy
Back to Top
cavaricooper View Drop Down
Intermediate Group
Intermediate Group


Joined: December-29-2013
Location: Tampa, FL
Points: 96
Post Options Post Options   Thanks (0) Thanks(0)   Quote cavaricooper Quote  Post ReplyReply Direct Link To This Post Posted: March-21-2019 at 7:30am
Randy-

Perhaps that is the difference- you use the mouse input whilst I out of necessity use the MMB emulator (as controls are disabled).

I hope Marniftarr is reading all this and developing the solution.

V3 is a big improvement but can not overlook the basics of the interface.

I appreciate your tests!

C
Back to Top
RRVyper View Drop Down
Senior Member
Senior Member


Joined: July-21-2017
Location: Canada
Points: 683
Post Options Post Options   Thanks (0) Thanks(0)   Quote RRVyper Quote  Post ReplyReply Direct Link To This Post Posted: March-21-2019 at 9:37am
Originally posted by cavaricooper cavaricooper wrote:

Perhaps that is the difference- you use the mouse input whilst I out of necessity use the MMB emulator (as controls are disabled).
I thought you were using your actual MMB. The EZCA emulated MMB (with FSUIPC mouselook enabled) seems to work like P3D mouse yoke, which does reset to 'zero' between presses (for obvious reasons - prevents wild control changes). Perhaps it's fixable.

Randy
Back to Top
cavaricooper View Drop Down
Intermediate Group
Intermediate Group


Joined: December-29-2013
Location: Tampa, FL
Points: 96
Post Options Post Options   Thanks (0) Thanks(0)   Quote cavaricooper Quote  Post ReplyReply Direct Link To This Post Posted: March-21-2019 at 10:02am
Randy-

It is my MMB but I have to have FSUIPC Mouse Look ticked as that is the only way SPOT pan will work.

I’m glad for the new features, just hope the historical interfaces can be fixed.

I have followed Marniftarr’s instructions about removing Mouae Look from P3D and assigning SPACE in List of Assignments.

Ta- C

Back to Top
RRVyper View Drop Down
Senior Member
Senior Member


Joined: July-21-2017
Location: Canada
Points: 683
Post Options Post Options   Thanks (0) Thanks(0)   Quote RRVyper Quote  Post ReplyReply Direct Link To This Post Posted: March-21-2019 at 10:44am
Ok. Understood now. Smile It doesn't sound like an EZCA problem then, since my MMB works as expected (meaning no reset to rear) when controls are disabled and FSUIPC mouselook is enabled. When you had EZCA uninstalled, did you try the SPOT mouselook (with controls disabled and FSUIPC mouselook enabled)? Something else that may have been different between us - I did a complete fresh install of P3Dv4.4 rather than an upgrade. You could also try disabling FSUIPC (DLL.xml), enabling your controls and seeing how SPOT behaves with the mouse (would be prudent to make a backup of Standard.xml just in case) just to rule out FSUIPC as the cause (I assume you are using v5.151). Another option is to backup then delete the FSUIPC.ini file (it will rebuild) and see if the issue still remains (enable FSUIPC mouselook and load default F22 scenario and check SPOT on the ground - you won't need your joystick for the test). If no joy, then replace the FSUIPC.ini file with your backup.

Slowly running out of ideas...Disapprove

Randy
Back to Top
cavaricooper View Drop Down
Intermediate Group
Intermediate Group


Joined: December-29-2013
Location: Tampa, FL
Points: 96
Post Options Post Options   Thanks (0) Thanks(0)   Quote cavaricooper Quote  Post ReplyReply Direct Link To This Post Posted: March-21-2019 at 10:57am
Randy-

I will test again this evening and report. I appreciate your continued interest... I hope Marniftarr is following all this closely.

C
Back to Top
cavaricooper View Drop Down
Intermediate Group
Intermediate Group


Joined: December-29-2013
Location: Tampa, FL
Points: 96
Post Options Post Options   Thanks (0) Thanks(0)   Quote cavaricooper Quote  Post ReplyReply Direct Link To This Post Posted: March-21-2019 at 12:18pm
To test fully, it would be great to have an idiot’s guide to uninstalling and/or rolling back to v2....

C
Back to Top
RRVyper View Drop Down
Senior Member
Senior Member


Joined: July-21-2017
Location: Canada
Points: 683
Post Options Post Options   Thanks (0) Thanks(0)   Quote RRVyper Quote  Post ReplyReply Direct Link To This Post Posted: March-21-2019 at 12:38pm
Carl, the reason your MMB resets to the rear in SPOT view is the edit you made in FSUIPC.ini (UseMidMouseBtn=No). Change it back to Yes and you should be OK. Then we can work on your VC issue. 

From further testing:
If I disable EZCA (and go back to original Cameras.cfg and Standard.xml), and set UseMidMouseBtn=No, I lose all ability to pan with the MMB, even though mouselook is checked in FSUIPC, which is what I would expect to happen. I can however use the Space key to activate mouselook since that is default for P3D (if controllers are enabled). And each press of the SPACE key resets the camera to the initial position (rear for SPOT). BUT, if I deselect mouselook in FSUIPC, the view does not reset. It remembers my mouse position from the previous press (of SPACE), even when changing from VC to SPOT. So, it appears that FSUIPC is responsible for the reset of the view. Finally, with FSUIPC disabled, and P3D controls at default, mouselook is only activated by SPACE or Shift+O.

Now, to put everything back to 'normal'. Smile

Randy
Back to Top
simperfi View Drop Down
Senior Member
Senior Member


Joined: January-11-2015
Location: GB
Points: 2791
Post Options Post Options   Thanks (0) Thanks(0)   Quote simperfi Quote  Post ReplyReply Direct Link To This Post Posted: March-21-2019 at 12:39pm

There is an alternative FSUIPC option


add the following key press assignment


set space key   on press = Mouselook On on release mouselook off

also check the box -- no repeat -- This is important

you still need mouselook checked in miscellaneous



the reset to cords 0,0 no longer applies - i.e space key press does not reset
to rear of aircraft

extract from FSUIPC guide

Mouse look: This operates in a similar way to the default P3D facility, but without needing Controllers enabled in P3D — be sure not to have it enabled if you do have controllers enabled in P3D as the two facilities will clash. As with the P3D facility, the mouse look option is turned on and off with the "MOUSE LOOK TOGGLE" control, which acts as a Toggle with parameter 0, or as an "ON" with parameter 1 and "OFF" with parameter 2. The latter two are assigned by default in P3D, to the space bar. Note there's one main difference from the P3D facility: when first engaged the view is reset to centre-forward. this is the "origin" (0,0) of the view coordinates and allows the proper axis controls to be used without knowing where the current view is pointing. Also, there is no "dead zone"—moving the mouse moves the view. To avoid this difference you can use the built-in FSUIPC controls instead of the P3D control. There are three: mouselook on, mouselook off, and mouselook toggle. If you want to still use the space bar, assign it in FSUIPC to mouselook on for 'press', and mouselook off for 'release' (without repeats). This will override the P3D assignment. However, you can also use the middle mouse button* which is predefined as "mouse look on" for press and "mouse look off" for release. Note that this use does not interfere with the mouse move option, if that is also enabled. The mouse move option needs fast single (or double) clicks of the middle button, whilst the mouse look requires you to hold down the button whilst moving the mouse for the view changes. Mouse zoom using the mouse wheel is also implemented and enabled by this checkmark. * The use of the middle mouse button can be inhibited by a parameter (UseMidMouseButton=No) in the INI file, which you can set if you need the middle button for aircraft-specific facilities. •
Kevin
Back to Top
RRVyper View Drop Down
Senior Member
Senior Member


Joined: July-21-2017
Location: Canada
Points: 683
Post Options Post Options   Thanks (0) Thanks(0)   Quote RRVyper Quote  Post ReplyReply Direct Link To This Post Posted: March-21-2019 at 1:03pm
Originally posted by simperfi simperfi wrote:


There is an alternative FSUIPC option
Excellent suggestion, Kevin. Good find! Thumbs Up
Back to Top
simperfi View Drop Down
Senior Member
Senior Member


Joined: January-11-2015
Location: GB
Points: 2791
Post Options Post Options   Thanks (0) Thanks(0)   Quote simperfi Quote  Post ReplyReply Direct Link To This Post Posted: March-21-2019 at 1:19pm

to be honest i just had a huch that there was more to this setup  fsuipc is an amazing tool 

currently i have been using the p3d experimental voice control function - as a checklist for performing   aircraft startup and  shutdown procedures 

now i want to test if interaction with ezca 3 is functional  it may be useful to older simmers like myself who may have limited dexterity in their hands  or fingers

Kevin
Back to Top
RRVyper View Drop Down
Senior Member
Senior Member


Joined: July-21-2017
Location: Canada
Points: 683
Post Options Post Options   Thanks (0) Thanks(0)   Quote RRVyper Quote  Post ReplyReply Direct Link To This Post Posted: March-21-2019 at 2:01pm
I noticed that yesterday when looking at the SDK. I hadn't even realized it was a feature in P3D. So used to just jumping in and flying. The only voice control I have used so far has been via FS2Crew. But, I agree with you on FSUIPC. Pete has created a very useful and powerful program. It's LUA functionality is handy as well. Smile

Randy
Back to Top
simperfi View Drop Down
Senior Member
Senior Member


Joined: January-11-2015
Location: GB
Points: 2791
Post Options Post Options   Thanks (0) Thanks(0)   Quote simperfi Quote  Post ReplyReply Direct Link To This Post Posted: March-21-2019 at 2:23pm
Originally posted by RRVyper RRVyper wrote:

I noticed that yesterday when looking at the SDK. I hadn't even realized it was a feature in P3D. So used to just jumping in and flying. The only voice control I have used so far has been via FS2Crew. But, I agree with you on FSUIPC. Pete has created a very useful and powerful program. It's LUA functionality is handy as well. Smile

Randy

LM has suggested that the function may be further enhanced in the next update to v4 
from posting in the p3d forum it seems it may be restricted to Language sets. English USA 
in windows 10 home and English uk plus english usa  in win 10 pro 

i will post a video of the ezdok interaction if it proves to be workable 
Kevin
Back to Top
cavaricooper View Drop Down
Intermediate Group
Intermediate Group


Joined: December-29-2013
Location: Tampa, FL
Points: 96
Post Options Post Options   Thanks (0) Thanks(0)   Quote cavaricooper Quote  Post ReplyReply Direct Link To This Post Posted: March-21-2019 at 7:28pm
ok- here's the report-

I only changed the UseMidMouseBtn=No back to YES, and tried SPOT- I did not use Kevin's solution, just have the Mousewheel Mouselook box ticked and it is working CORRECTLY.

However, my VC issue of jumping around with the mouse is now back.

I am going to apply Kevin's fix- keeping the MouseBtn=Yes 

Ok- with Kevin's fix- SPOT works fine- BUT MY VC issue is back- jumping all over the place once the MMB is pressed once to move the view.  As long as I do not press the MMB I am fine- as soon as I do- chaos.

The only thing left is to go back to UseMidMouseBtn=No and try Kevin's fix...

Marniftarr- you have awesome supporters here- but are YOU reading all this??

C
Back to Top
cavaricooper View Drop Down
Intermediate Group
Intermediate Group


Joined: December-29-2013
Location: Tampa, FL
Points: 96
Post Options Post Options   Thanks (0) Thanks(0)   Quote cavaricooper Quote  Post ReplyReply Direct Link To This Post Posted: March-21-2019 at 7:51pm
Ok- I did that as well-

The view still resets to the rear every time I press the MMB in SPOT.

Time to fly- this is the workday continuing... :)

Hopefully we will see another beta soon.

C
Back to Top
RRVyper View Drop Down
Senior Member
Senior Member


Joined: July-21-2017
Location: Canada
Points: 683
Post Options Post Options   Thanks (0) Thanks(0)   Quote RRVyper Quote  Post ReplyReply Direct Link To This Post Posted: March-21-2019 at 8:28pm
Carl,
Any chance of posting a video (of the VC issue)? I think you said you don't use TrackIR. It almost sounds like your mouse is fighting with something else that is trying to control the view. But, even when I enable TrackIR, enable Look Around, AND enable Active Zoom, everything is smooth and it doesn't conflict. Is Eliminate Blinks enabled? 

You might have to use Kevin's solution until you get a reply from Marniftarr or Nick. He mentioned he also has the VC flashes, and you both use FSUIPC exclusively for your joysticks so maybe you can solve it together. I just can't replicate it on my machine no matter what I try.

I'll post my settings below to see if anything jumps out at you. Good luck! Thumbs Up











Back to Top
cavaricooper View Drop Down
Intermediate Group
Intermediate Group


Joined: December-29-2013
Location: Tampa, FL
Points: 96
Post Options Post Options   Thanks (0) Thanks(0)   Quote cavaricooper Quote  Post ReplyReply Direct Link To This Post Posted: March-22-2019 at 3:11pm
Randy-

My setup is exactly as yours, other than I use 3 input devices.  I do have the Warthog system, but I only use that for DCS.  For P3D and PSX I use a PFC Controls Console, TQ and Rudders.

At the moment I have SPOT working, without VC interactions.  The only limitation is that each time I press my MMB the SPOT resets to tail forward view.  I can live with that for now.

I hope that we get an update solving these issues.  Regular communications would be most appreciated.

Best- C
Back to Top
 Post Reply Post Reply Page  <1 3456>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.01
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.172 seconds.