SimForums.com Homepage
Forum Home Forum Home > Flight One Partner Forums > EZdok Software > EZdok Beta Forum
  New Posts New Posts RSS Feed - EZCA 3.1 for P3D v5 here!!! (beta)
  FAQ FAQ  Forum Search   Register Register  Login Login

EZCA 3.1 for P3D v5 here!!! (beta)

 Post Reply Post Reply Page  <1 345
Author
Message
RRVyper View Drop Down
Senior Member
Senior Member


Joined: July-21-2017
Location: Canada
Points: 847
Post Options Post Options   Thanks (0) Thanks(0)   Quote RRVyper Quote  Post ReplyReply Direct Link To This Post Posted: May-26-2020 at 1:21pm
It's never a good idea to play around in the WinSxS folder. It's locked down for a reason. But, if you DO want to modify things, you need to take permission from the TrustedInstaller (WinSxs folder/properties/security/advanced/ then Owner: change). It's probably better to reinstall the simconnect files (as administrator). That should work, but I can't test it.

Randy
Back to Top
krlskris View Drop Down
New Member
New Member


Joined: May-26-2020
Location: Spain
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote krlskris Quote  Post ReplyReply Direct Link To This Post Posted: May-26-2020 at 4:14pm
Yes, following your instructions, I have changed the owner to my administrator user and from there I have granted the necessary permissions to manage the folders.
After copying the folder C: \ Windows.old \ windows \ winSxsªx86_micorosfot.flight ... to C: \ Windows \ winsxs I let it take the TrustedInstaller control again so that the folders are protected again.
Ezca 3.1 works like this perfectly in Windows 10 2004.
Thank you very much for your help
Back to Top
RRVyper View Drop Down
Senior Member
Senior Member


Joined: July-21-2017
Location: Canada
Points: 847
Post Options Post Options   Thanks (0) Thanks(0)   Quote RRVyper Quote  Post ReplyReply Direct Link To This Post Posted: May-26-2020 at 4:23pm
Originally posted by krlskris krlskris wrote:

Yes, following your instructions, I have changed the owner to my administrator user and from there I have granted the necessary permissions to manage the folders.
After copying the folder C: \ Windows.old \ windows \ winSxsªx86_micorosfot.flight ... to C: \ Windows \ winsxs I let it take the TrustedInstaller control again so that the folders are protected again.
Ezca 3.1 works like this perfectly in Windows 10 2004.
Thank you very much for your help
That's good news, Carlos. Glad you got it working. Clap

Randy
Back to Top
david roch View Drop Down
Senior Member
Senior Member


Joined: February-08-2004
Location: Israel
Points: 209
Post Options Post Options   Thanks (0) Thanks(0)   Quote david roch Quote  Post ReplyReply Direct Link To This Post Posted: May-29-2020 at 9:26am
Originally posted by Dirk98 Dirk98 wrote:

Originally posted by Mr BlueSky Mr BlueSky wrote:

Yes I can confirm that is the reason. Had the same issue with simconnect after 2004 update.
You can fix this by copying the 4 x86-Microsoft.fsx folders (containig the 4 versions of simconnect.dll you should have installed) in the windows.old folder c:\ windows.old\WinSxs\Fusion path to the current (2004) C:\Windows\WinSxs\Fusion folder. You will need to be logged on as administrator to do this. Ezca 3.1 now working for me.

2004 update build 19631.1 here. If you run simconnect installers from the redist folder in Prepar3D v5 to some reason the dlls get installed under Windows\WinSxs\Fusion folder and this is the problem. Soon as I copied the dlls (under their respective folders) directly do WinSxs folder (from Fusion folder!!) EZCA resumed connecting Ok. Thanks for giving me an idea where to look for the cause of the problem.  

Cheers,


Well I did that but it doesn't work.
EZCA3.1 doesn't find Simconnect.
Build 19635.1 here.

Help, please!
Cheers,

My rig:
1 PC, 1 monitor, 1 keyboard and a mouse.

Back to Top
krlskris View Drop Down
New Member
New Member


Joined: May-26-2020
Location: Spain
Points: 9
Post Options Post Options   Thanks (1) Thanks(1)   Quote krlskris Quote  Post ReplyReply Direct Link To This Post Posted: May-29-2020 at 5:37pm
You must copy the directory that is created in Windows.old \ WinSxS (x86_microsoft.flightsimulator.simconnect ... etc to Windows / WinSxS.
This is how it works for me.
Back to Top
david roch View Drop Down
Senior Member
Senior Member


Joined: February-08-2004
Location: Israel
Points: 209
Post Options Post Options   Thanks (0) Thanks(0)   Quote david roch Quote  Post ReplyReply Direct Link To This Post Posted: May-29-2020 at 6:12pm
Thanks, Kris,
Unfortunately, after few Win10 2004 updates I don't have the Windows.old folder anymore.
Do you mind sending me a zip with the simconnect folders?
I'll send you my email address by PM.
My rig:
1 PC, 1 monitor, 1 keyboard and a mouse.

Back to Top
RRVyper View Drop Down
Senior Member
Senior Member


Joined: July-21-2017
Location: Canada
Points: 847
Post Options Post Options   Thanks (1) Thanks(1)   Quote RRVyper Quote  Post ReplyReply Direct Link To This Post Posted: May-29-2020 at 10:23pm
I think another option would be to reinstall the Simconnect files and copy them to where you need them.

Randy
Back to Top
david roch View Drop Down
Senior Member
Senior Member


Joined: February-08-2004
Location: Israel
Points: 209
Post Options Post Options   Thanks (0) Thanks(0)   Quote david roch Quote  Post ReplyReply Direct Link To This Post Posted: May-30-2020 at 2:49am
Thanks to Kris, it works now. Smile
There was one folder missing in the WinSxS directory (only 3).
After adding the 4th folder, EZCA is back.

For those with the same issue, I have put the folder for download here:
https://www.dropbox.com/sh/ncm3ezzh4d8lyb8/AAD5f66DUxuNVCcpdXyXCu_Ka?dl=0
Thanks all!

My rig:
1 PC, 1 monitor, 1 keyboard and a mouse.

Back to Top
bc621 View Drop Down
Senior Member
Senior Member


Joined: November-30-2009
Points: 396
Post Options Post Options   Thanks (0) Thanks(0)   Quote bc621 Quote  Post ReplyReply Direct Link To This Post Posted: May-30-2020 at 11:53am
Dave thank you. You saved my life. I have downloded your folder and now ezc finally works.
Back to Top
david roch View Drop Down
Senior Member
Senior Member


Joined: February-08-2004
Location: Israel
Points: 209
Post Options Post Options   Thanks (0) Thanks(0)   Quote david roch Quote  Post ReplyReply Direct Link To This Post Posted: May-30-2020 at 12:36pm
Beer
My rig:
1 PC, 1 monitor, 1 keyboard and a mouse.

Back to Top
331BK View Drop Down
New Member
New Member


Joined: June-23-2013
Location: Austria
Points: 12
Post Options Post Options   Thanks (0) Thanks(0)   Quote 331BK Quote  Post ReplyReply Direct Link To This Post Posted: 7 hours 18 minutes ago at 1:30pm
Tried to copy from the windows.old folder but it i got the message that i don`t have rights to copy somehting in the winSxS folder.

lg
Back to Top
 Post Reply Post Reply Page  <1 345
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.01
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.094 seconds.