SimForums.com Homepage
Forum Home Forum Home > Flight One Software Forums > Ground Environment X Series
  New Posts New Posts RSS Feed - [ANSWERED] "Autogen Forrest Performance Fix"
  FAQ FAQ  Forum Search   Register Register  Login Login

[ANSWERED] "Autogen Forrest Performance Fix"

 Post Reply Post Reply
Author
Message
GEK_the_Reaper View Drop Down
New Member
New Member


Joined: January-12-2017
Points: 32
Post Options Post Options   Thanks (0) Thanks(0)   Quote GEK_the_Reaper Quote  Post ReplyReply Direct Link To This Post Topic: [ANSWERED] "Autogen Forrest Performance Fix"
    Posted: April-11-2019 at 1:56am
Hello,

as the title says, I found out that the "AFPF" option places some trees where they should not be.

I bought the Aerosoft Friedrichshafen Proffesional and always had Trees in the landing path of RWY24.
I found some reports dating back as far as 2012 where the fix was to simply re-order some scenery priorities. In P3D v4.4 that action could not be taken because some of the sceneries can not be moved (at least not using P3D's GUI).

After some trial and error I found out that unchecking "AFPF" removes the unwanted trees.
See this topic for pictures (It's not that long).

I suspect that this happens on more airports where runways are located near forrests...
P3D v4, GEP3D+UTX, ASP4+ASCA, FSGlobal Ultimate NG, ORBX Trees HD, Chase Plane,...
Back to Top
NickN View Drop Down
Certified Professional
Certified Professional


Joined: November-21-2007
Points: 17598
Post Options Post Options   Thanks (0) Thanks(0)   Quote NickN Quote  Post ReplyReply Direct Link To This Post Posted: April-12-2019 at 12:09pm
If you cant move items up or down the scenery library list then there is a problem on your end with that. You should not have any trouble moving listed scenery items up or down.
 
 
As for the autogen performance fix, there is nothing wrong. If there is issue or discrepancy with a scenery addon, turn it off (uncheck the option in the interface) as we outline on page 9 under the section:

AG FOREST PERFORMANCE FIX - PLEASE NOTE THE FOLLOWING... If you are seeing trees on runways or other places they should not appear

 
It helps to read the manual.
 
One of 3 other possibilities... The issue could be the scenery designer did not place exclusions for their scenery in that location. If the landclass is calling a tree tile for the location and if the scenery that is overlaying that tile does not have the proper exclusion code for the specific location, then marked vegetation on the underlying layer could show through the scenery.
 
OR
 
Some kind of Orbx scenery issue (which can be trees too) even disabling that or uninstalling may not restore the control files they change.
 
OR
 
There was a bug in FSX from years back in the terrain.cfg that affected addon scenery. https://www.simforums.com/forums/solved-addon-scenery-has-black-areas-trees_topic51510_post326665.html#326665  The fix was to open the terrain.cfg in notepad (for P3D: C:\ProgramData\Lockheed Martin\Prepar3D v4    terrain.cfg
 
 
Scroll down to these 4 entries and if they are less than 200000 change the RENDER ORDER number from 20000 to 200000 then save the terrain.cfg
 
 
You can always save a copy of the original terrain.cfg first so if this doesn't help you can simply overwrite the edited version with the original.
 
 
// Airport Backgrounds (FSX) - Flatten + MaskClassMap + ExcludeAutoGen
[Texture.164]

Name=Airport_Backgrounds_Flatten_MaskClassMap_ExcludeAutoGen
Color=FFFFFF00
guid={46BFB3BD-CE68-418E-8112-FEBA17428ACE}
FlattenMode=flat
FlattenPriority=51000
LandClassRemapType=airport
ExcludeAutogen=Yes
RenderToTexture=No
RenderPriority=200000
Water=No
 
 
The rest of the entries are:
 
 
 
// Airport Backgrounds (FSX) - Flatten + ExcludeAutoGen
[Texture.165]

Name=Airport_Backgrounds_Flatten_ExcludeAutoGen
Color=FFFFFF00
guid={18580A63-FC8F-4A02-A622-8A1E073E627B}
FlattenMode=flat
FlattenPriority=51000
LandClassRemapType=none
ExcludeAutogen=Yes
RenderToTexture=No
RenderPriority=200000
Water=No
 
 
// Airport Backgrounds (FSX) - MaskClassMap + ExcludeAutoGen
[Texture.166]

Name=Airport_Backgrounds_MaskClassMap_ExcludeAutoGen
Color=FFFFFF00
guid={594E70C8-06A5-4E3F-BE6E-4DBF50B49D11}
FlattenMode=none
LandClassRemapType=airport
ExcludeAutogen=Yes
RenderToTexture=No
RenderPriority=200000
Water=No
 
 
// Airport Backgrounds (FSX) - ExcludeAutoGen
[Texture.264]

Name=Airport_Backgrounds_ExcludeAutoGen
Color=FFFFFF00
guid={6C0C6528-5CF1-483A-A586-2C905CF2757E}
FlattenMode=none
LandClassRemapType=none
ExcludeAutogen=Yes
RenderToTexture=No
RenderPriority=200000
Water=No
 
 
 
Re-enable the AG tree fix in the GEP3D interface. (run as administrator). Close the GEP3D interface and launch the sim. Check your scenery now.
 
 
If you still have trees on airport areas where they should not be then DISABLE the autogen forest tree performance fix in the GEP3D interface (uncheck this in the GEP3D interface with P3D closed) and leave it disabled.
 
 
If the trees are gone after editing the above with the GEP3D forest performance fix enabled,... then its a combination of the airport scenery and P3D terrain.cfg causing the issue, not GEP3D.
 
 
 
 

Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.01
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.172 seconds.