SimForums.com Homepage
Forum Home Forum Home > Flight One Partner Forums > Opus Software
  New Posts New Posts RSS Feed - FSIGENCOM error
  FAQ FAQ  Forum Search   Register Register  Login Login

FSIGENCOM error

 Post Reply Post Reply
Author
Message
Peter VO View Drop Down
New Member
New Member


Joined: October-08-2010
Points: 23
Post Options Post Options   Thanks (0) Thanks(0)   Quote Peter VO Quote  Post ReplyReply Direct Link To This Post Topic: FSIGENCOM error
    Posted: October-09-2019 at 4:51am
Hello,
I do have a small (?) problem. I have 3 computers running OpusFSI (1 server and 2 clients). I just did an upgrade from version 23.x versus 28.4. Worked fine for server and 1 client. On the second client I get "Unhandled exception", unable to load DLL 'fsigencom.ddl'... Server is Win10, clients are identical (apparently not Wink) Win7 with FSX... Any help appreciated...(in the meantime combination of 2 versions work well)

Thanks


Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 13881
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: October-09-2019 at 8:30am
The first things to check on your 2nd client would be ...

Have you installed the latest software in its default c:\OpusFSI_v5 folder?

Have you checked to see that the FSIGENCOM.DLL library file exists in that folder?

Were you running the FSICLIENT.EXE in Admin Mode and starting in the above folder?

Stephen
Back to Top
Peter VO View Drop Down
New Member
New Member


Joined: October-08-2010
Points: 23
Post Options Post Options   Thanks (0) Thanks(0)   Quote Peter VO Quote  Post ReplyReply Direct Link To This Post Posted: October-09-2019 at 9:28am
Hi Stephen,

yes,

yes,

I tried in Admin and normal mode (fyi on second client, FSIClient is started in normal mode - but having, like on all my computers- admin rights), starting in right directory...

Thanks for your research,

Peter
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 13881
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: October-09-2019 at 10:23am
windows is reporting it could not find the fsigencom.dll.

Try creating a desktop shortcut as per our GS Guide and make sure you set it to Start In the c:\OpusFSI_v5 folder.

If the FSICLIENT.EXE is not starting in the correct folder then the activated FSXCLIENT.EXE would not be able to locate its fsigencom.dll library file.

You could also uninstall, delete all exe and dll files, then install using the msi file and run it again.

Your C drive should also be shared with permissions.

Stephen

Stephen
Back to Top
Peter VO View Drop Down
New Member
New Member


Joined: October-08-2010
Points: 23
Post Options Post Options   Thanks (0) Thanks(0)   Quote Peter VO Quote  Post ReplyReply Direct Link To This Post Posted: October-09-2019 at 12:45pm
Hi Stephen,

"Try creating a desktop shortcut as per our GS Guide and make sure you set it to Start In the c:\OpusFSI_v5 folder" : I already had a correct shortcut (cfr 2nd client), but have made a new one but to no avail

"If the FSICLIENT.EXE is not starting in the correct folder then the activated FSXCLIENT.EXE would not be able to locate its fsigencom.dll library file." : I understand, but the file is present in the correct directory

"You could also uninstall, delete all exe and dll files, then install using the msi file and run it again." : have done so, version 28.4 is not working (same thing done with versions 23 and 22 and FSIClient is working like it should).

"Your C drive should also be shared with permissions.": has not changed, but verified anyway (problem is not there)



Verified all files, permissions and shortcut with 2nd client (so other client machine)

Still no luck


Not too urgent, but enigmatic

Cheers,
Peter
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 13881
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: October-09-2019 at 12:50pm
With the latest ver 5.28.4 installed use the vcredist_x86.exe to install the MS VC 32-bit redistribution pack. Also make sure Windows is up to date.

Stephen
Back to Top
Peter VO View Drop Down
New Member
New Member


Joined: October-08-2010
Points: 23
Post Options Post Options   Thanks (0) Thanks(0)   Quote Peter VO Quote  Post ReplyReply Direct Link To This Post Posted: October-09-2019 at 12:56pm
ok,

even if win7 is 64-bits ? I have no access to my FS computers, so have to check tomorrow. All my computers are up to date (which causes sometimes Strange behaviours )

Thanks Stephen
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 13881
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: October-09-2019 at 12:58pm
yes, you need the 32-bit VC redistribution pack as OpusFSI and fsigencom.dll is 32-bit.

Stephen
Back to Top
Peter VO View Drop Down
New Member
New Member


Joined: October-08-2010
Points: 23
Post Options Post Options   Thanks (0) Thanks(0)   Quote Peter VO Quote  Post ReplyReply Direct Link To This Post Posted: October-10-2019 at 5:18am
Hi Stephen,

having C++ redistribution packages from 2008...2019, I had not noticed that the 2013 version was missing...

Thumbs Up

and that did the trick (lesson: rtfm)

Thanks,

Peter
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.01
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.109 seconds.