SimForums.com Homepage
Forum Home Forum Home > Flight One Software Forums > Ground Environment X Series
  New Posts New Posts RSS Feed - Windows 7 - 8 - 10: UAC BLOCKS GEX/GEP3D INTERFACE
  FAQ FAQ  Forum Search   Register Register  Login Login

Topic ClosedWindows 7 - 8 - 10: UAC BLOCKS GEX/GEP3D INTERFACE

 Post Reply Post Reply
Author
Message
 Rating: Topic Rating: 1 Votes, Average 5.00  Topic Search Topic Search  Topic Options Topic Options
NickN View Drop Down
Certified Professional
Certified Professional


Joined: November-21-2007
Points: 16707
Direct Link To This Post Topic: Windows 7 - 8 - 10: UAC BLOCKS GEX/GEP3D INTERFACE
    Posted: May-04-2013 at 7:15am
 
NOTE: BLURRY SCENERY IS NOT A UAC ISSUE. IF YOUR INTERFACE DISPLAYS 'ENABLED IN FSX' or "ENABLED in P3D AND YOU SEE NO CHANGE IN FSX/P3D AND YOUR SCENERY IS BLURRY THIS IS A SLOW COMPUTER HARDWARE ISSUE WITH RESPECT TO THE FSX DEMAND ON THE HARDWARE. GEX/GEP3D WILL NOT CAUSE BLURRY SCENERY. http://www.simforums.com/forums/solved-ground-environment-x-europe-not-working_topic45966_post275906.html
 
 
 
 
Windows UAC (User Access Control) has limited value in protecting a single user computer. It was designed to protect OFFICE NETWORKS from malware spreading across the network but in many cases it will not protect the original computer system the malware was executed on.
 
If you use FSX/P3D and 3rd party addons by now you are probably already aware that User Access Control can block proper function of addons.. We always recommend that UAC should be completely shut down as well as Windows Defender for both system performance as well as stop issues with running addons.
 
The symptoms of UAC blocking GEX/GEP3D are as follows:
 
Note; it is possible to see all or only ONE of these
 
1. Interface launch license failure
 
2. The interface constantly complains it can not locate the backup folder
 
3. Upon reopen of the GEX or GEP3D interface, the GEX/GEP3D regions RESET from ENABLED to DISABLED
 
4. Along with #3 above, upon reopen of the GEX/GEP3D interface the interface may run through the backup process for some regions even though it has run the process in the past.
 
5. No texture changes in FSX/Prepar3D
 
 
 
 
PLEASE NOTE that shutting down UAC in Windows 8 is different than shutting down UAC in Windows 7
 
To disable UAC in Windows do the following:
 
 
 
 
WINDOWS 7 (including Vista)
 
 
To shut down UAC in Windows 7 its simple and easy to accomplish, do the following:
 
 
1. Go to Control Panel - User Accounts - Change User Account Control Settings
 
You can also click START and in the search box type: UAC then click on; Change User Account Control Settings
 
 
2. In the box that appears set the sider to ZERO (Never Notify) and click OK and reboot the computer.
 
Done
 
 
Once you have disabled UAC then re-run the GEX/GEP3D interface and select to ENABLE the regions
 
If the regions were showing enabled then DISABLE and ENABLE them again.
 
 
 
 
 
 
 
---------------------------------------------------------------------------------------
 
 
 
WINDOWS 8
 
 
Windows 8 presents a real problem when it comes to UAC. Microsoft found it in their infinite wisdom to leave UAC enabled even if the UAC slider is set to NEVER NOTIFY.
 
What I am going to suggest here is theory since I personally can not test it since I do not use Windows 8, however from user feedback it does appear to work.
 
 
METHOD 1:
 

VERY IMPORTANT:  For this method to work, FSX, FS2004, P3D or any add-on product MAY NOT be installed in a "windows protected area/folder/directory" such as


\Program Files
\Program Files (x86)

 

You MUST install FSX/P3D to a folder you create on your main (C:) drive or alternative separate drive.

 
EXAMPLE: C:\FSX  or    F:|Flightsim    or install FSX/P3D any folder outside of the directories shown above 
 
 
This method WILL NOT completely disable UAC in Windows 8 but will reduce its impact on applications and should work.
 
1. GO to Control Panel - User Access Control and in the box that appears set the slider to ZERO (Never Notify) click OK and reboot.
 
2. When ever you run a Flight1 Wrapper and/or any addon product installer, always right click the EXE file and select RUN AS ADMINISTRATOR.
 
3. When ever you RUN the GEX interface, right click the GEX shortcut and select RUN AS ADMINISTRATOR
 
 
 
If the above does not work and you continue to have issues with running the GEX interface and getting the textures to install, then use METHOD 2 below
 
 
 
 
Method 2:
 
This method WILL completely disable UAC in Windows 8 however it does come with one side effect. In Windows 8 if you completely disable UAC the "Metro Apps" will not function. If you do not care about "Metro Apps" and do not use them then to disable UAC completely do the following:
 

1: Open registry editor by pressing the Windows + R key at the same time, then in the RUN box that appears type: regedit dialogue box and hit enter.

2: In regedit, navigate to the following key:

 
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

In the right pane look for EnableLUA, double click it and modify its value to 0. Close regedit and reboot.
 
 
UAC is now completely disabled.
 
 
------------------------------------------------------------------------
 
 
 
NOTE: IF you want to use Windows 8 Metro Apps and completely disable UAC at the same time then you must jump through a few hoops and ladders to set that up as defined here: http://www.alltechtalk.net/2012/09/04/bypass-windows-8-uac-while-keeping-metro/
 
 
===============================================
 
 
 
 
 
Windows 10

1. Open the Control Panel (icons view) and select User Accounts.

2. Click on the Change User Account Control settings link. If prompted by UAC, click on Yes to continue.

3. In the User Account Control settings, move the slider to the bottom (Never Notify).

4. Reboot
 
 
 
------------------------------------------------------------------
 
 
 
Once you have disabled UAC then re-run the GEX/GEP3D interface and select to ENABLE the regions
 
If the regions were showing enabled then DISABLE and ENABLE them again.
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Back to Top
NickN View Drop Down
Certified Professional
Certified Professional


Joined: November-21-2007
Points: 16707
Direct Link To This Post Posted: October-29-2013 at 1:33pm
 
 
 
 
 
License issues can be because you installed GEX with UAC or other security products enabled, then disabled them after the fact whereby the license files did not install.  
 
 
Make SURE GEX is decompressed from the purchase wrapper, or, installed from the DVD AFTER you have disabled UAC/Defender and AV/Malware scanners so the license files properly write to the system. Here is a thread that may help: http://www.simforums.com/forums/solved-windows-8-gex-activation-problem_topic47632.html
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.10
Copyright ©2001-2017 Web Wiz Ltd.

This page was generated in 0.141 seconds.