SimForums.com Homepage
Forum Home Forum Home > Flight One Software Forums > Ground Environment X Series
  New Posts New Posts RSS Feed - [SOLVED] Problem with use in two P3D installation
  FAQ FAQ  Forum Search   Register Register  Login Login

[SOLVED] Problem with use in two P3D installation

 Post Reply Post Reply
Author
Message
oglitsch View Drop Down
New Member
New Member


Joined: December-26-2008
Location: Switzerland
Points: 25
Post Options Post Options   Thanks (0) Thanks(0)   Quote oglitsch Quote  Post ReplyReply Direct Link To This Post Topic: [SOLVED] Problem with use in two P3D installation
    Posted: August-06-2017 at 10:19am
I have just downloaded and updated version 1.10 of GEP3D for Prepar3d V3. Now I wanted to use it for V4 as well and I tried to follow your instruction as described here. I renamed prepar3d.exe by adding the suffix .temp but after starting the GEP3D interface (in Admin mode) it doesn't request me to browse to the location of Prepar3d. Thus I am not able to use it in Version 4.
Any idea what is going wrong?
Thanks for help.
Back to Top
NickN View Drop Down
Certified Professional
Certified Professional


Joined: November-21-2007
Points: 16707
Post Options Post Options   Thanks (0) Thanks(0)   Quote NickN Quote  Post ReplyReply Direct Link To This Post Posted: August-06-2017 at 6:00pm
That's strange
 
Are you sure you are renaming the right Prepar3d.exe in the P3Dv3 install directory and not the one in v4 exe?  Or perhaps a very old Prepar3D install you may be confusing with the current P3Dv3?
 
If GEP3D does not see the original Prepar3D.exe it was pointed to last on interface launch it is designed to instantly request a browse when the interface is opened on target check. There is no way that will not happen other than:
 
1. You renamed the wrong Prepar3D.exe instead of the original target
 
2. You left the interface open during the name swap and did not close before
 
3. RARE but possible: You have a P3D v1x or 2x install on your system. The interface will scan the registry and if there is a 1x or 2x version somewhere it will automatically default to that version if the original v3 or v4 is renamed. 
 
NOTE on #3: We did away with the registry check past P3D v2.x because of all the versions and the registry changes coming for v3, v4, vX, and, so on. The interface will default to a confirmed v1x or 2x P3D install if the original target of a higher version number is not found.
 
I have never come across anyone running v1/v2 with v3 and v4, therefore this is a situation that would be rare, but possible. If you have a P3D v1x or v2x installation on your system, rename Prepar3D.exe in those directories and then launch the GEP3D interface.
 
Can you review these and let me know?
 
 
Back to Top
oglitsch View Drop Down
New Member
New Member


Joined: December-26-2008
Location: Switzerland
Points: 25
Post Options Post Options   Thanks (0) Thanks(0)   Quote oglitsch Quote  Post ReplyReply Direct Link To This Post Posted: August-07-2017 at 4:27am
Thanks for your quick answer.

I have only two versions of Prepar3D.exe running: version 3 and 4. And yes, I renamed the correct Prepar3D.exe from version 3 while the interface was closed. Because I also suspected that maybe another Prepar3D.exe file exists somewhere I carried out a search through all drives of my computer. And indeed, I found 4 other Prepar3D.exe files which were backups of earlier installations. But even after deleting all these files, the GEP3D interface does not ask me for the path of the Prepar3D.exe.

I also tried to rename both, version 3 and 4 of Prepar3D.exe at the same time, in order to force the interface to ask for a path, but even then I was not asked for the path. In a last attempt I completely uninstalled GEP3D and started the installation from scratch - no change. That's why
I suspect that there is still a registry entry or an old config file existing somewhere...
Back to Top
NickN View Drop Down
Certified Professional
Certified Professional


Joined: November-21-2007
Points: 16707
Post Options Post Options   Thanks (0) Thanks(0)   Quote NickN Quote  Post ReplyReply Direct Link To This Post Posted: August-07-2017 at 1:58pm
If that is the case then I would question if GEP3D was originally pointed at your Prepar3Dv3 installation and would have to ask these questions:
 
After you updated to GEP3D v1.10 and first ran the interface did it request a browse?
 
Did you browse the interface to your P3Dv3 install?
 
 
If so I cant see a older registry being the issue but given so many P3D's on one system it may bring on a special situation. Lets try the following which should override any other target location....
 
 
1. Browse to: C:\Users\<Your User Name>\AppData\Roaming\Flight1 Aviation Technologies\GEP3D
 
2. Open the GEP3D directory
 
3. Right click the file: GEP3D_config.ini and select to open it in notepad
 
4. Under the [Main] header there may, or, may not be the following entry with address location data:

P3DPath=
 
a. If the entry shown above is present with a path, change the path to your Prepar3Dv4 install directory. Confirm that path is correct, then save and close the GEP3D_config.ini file
 
Example:
P3DPath=D:\Prepar3D_ProV4\ 
 
Note: Make sure the path has a backslash at the end as show and not just the directory name.
 
b. If the entry shown above is not present, add the entry P3DPath= anywhere under the [MAIN] header and then add the path to P3Dv4 using the example above as a guide. Save and close the GEP3D_config.ini file.
 
When you open the interface it will now be directed to ignore any registry and open directly to your Prepar3Dv4 install as long as it finds Prepar3D.exe in that location.
 
If your GEP3D was enabled in P3Dv3 it will continue to display ENABLED IN P3D, simply disabled and then re-enable. If you use any UTX products the interface should detect those and you can now enable them for P3Dv4.
 
In your case and if you need to switch back to P3Dv3, simply perform the same steps above and change the path in the GEP3D_config.ini file.
 
 
 
 
Back to Top
NickN View Drop Down
Certified Professional
Certified Professional


Joined: November-21-2007
Points: 16707
Post Options Post Options   Thanks (0) Thanks(0)   Quote NickN Quote  Post ReplyReply Direct Link To This Post Posted: August-10-2017 at 1:59pm
Were you able to resolve this with the suggestion I made?
Back to Top
oglitsch View Drop Down
New Member
New Member


Joined: December-26-2008
Location: Switzerland
Points: 25
Post Options Post Options   Thanks (0) Thanks(0)   Quote oglitsch Quote  Post ReplyReply Direct Link To This Post Posted: August-14-2017 at 5:13am
Sorry for my late answer - I was on holiday. Thank you very much for your latest suggestion - I will try it this evening and report whether I was succeful or not.
Back to Top
oglitsch View Drop Down
New Member
New Member


Joined: December-26-2008
Location: Switzerland
Points: 25
Post Options Post Options   Thanks (0) Thanks(0)   Quote oglitsch Quote  Post ReplyReply Direct Link To This Post Posted: August-14-2017 at 6:52pm
Today, I did as suggested in your last reply. Unfortunately, GEP3D is still linked to Version 3.

My GEP3D_config.ini showed the following entries:

[Main]
FirstRun=0
AutogenFix=1
Backup=D:\GEP3D_BACKUP
X=101
Y=149

Therefore, I added the line P3DPath=D:\Prepar3D v4\ to this file (yes, the P3D installation created a folder with a blank between 3D and v4). Now this ini file looks like this:

[Main]
P3DPath=D:\Prepar3D v4\
FirstRun=0
AutogenFix=1
Backup=D:\GEP3D_BACKUP
X=101
Y=149

The path to Prepar3d v4 is shown in this screenshot: http://www.glitsch.ch/flusi/path.png

Again, I did a search throughout all partitions of my computer to make sure there is only one Prepar3D.exe existing.

The strange thing is that the GEP3D interface http://www.glitsch.ch/flusi/GEX.jpg shows now a red button for UTX USA or Canada whereas it was green before re-install (UTX is NOT installed yet in P3D v4 yet - only in v3).
Back to Top
NickN View Drop Down
Certified Professional
Certified Professional


Joined: November-21-2007
Points: 16707
Post Options Post Options   Thanks (0) Thanks(0)   Quote NickN Quote  Post ReplyReply Direct Link To This Post Posted: August-14-2017 at 7:21pm
Ok I cant see the drive path in your image, I assume its D:\
 
I can tell you without any uncertainty that if you have
 
P3DPath=D:\Prepar3D v4\
 
..and you are running as administrator, you are pointed to: D:\Prepar3D v4\
 
unless there is a completely off the wall circumstance I cant reproduce here and I have tried every way to replicate the problem
 
The path= trumps all other possible targets
 
Verified with V1-V2-V3 and V4
 
If that path is in the ini and you are right click, launch as administrator there is absolutely no deviation for the product.   I have tried them all over and over
 
 
 
Back to Top
oglitsch View Drop Down
New Member
New Member


Joined: December-26-2008
Location: Switzerland
Points: 25
Post Options Post Options   Thanks (0) Thanks(0)   Quote oglitsch Quote  Post ReplyReply Direct Link To This Post Posted: August-15-2017 at 4:23pm
Hi Nick,

The problem is solved! I completely uninstalled GEP3D and re-installed it. Additionally, I also renamed the folder Prepar3d v4 (was not easy due to an undeletable font...). Now the interface shows the correct entries and Prepar3d v4 looks great now.

I thank you very much for your patience and helpful tips!Thumbs Up
Back to Top
NickN View Drop Down
Certified Professional
Certified Professional


Joined: November-21-2007
Points: 16707
Post Options Post Options   Thanks (0) Thanks(0)   Quote NickN Quote  Post ReplyReply Direct Link To This Post Posted: August-15-2017 at 11:56pm
All in all a strange situation. Reads as there was something wrong with the path name of P3Dv4 in combination with a possible registry issue the GEP3D reinstall repaired.
 
 
Glad it fixed Beer
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.10
Copyright ©2001-2017 Web Wiz Ltd.

This page was generated in 0.172 seconds.