SimForums.com Homepage
Forum Home Forum Home > Flight One Partner Forums > Opus Software
  New Posts New Posts RSS Feed - Server stops after a while
  FAQ FAQ  Forum Search   Register Register  Login Login

Server stops after a while

 Post Reply Post Reply
Author
Message
fedorklootwijk View Drop Down
New Member
New Member


Joined: March-01-2015
Location: Netherlands
Points: 18
Post Options Post Options   Thanks (0) Thanks(0)   Quote fedorklootwijk Quote  Post ReplyReply Direct Link To This Post Topic: Server stops after a while
    Posted: March-17-2017 at 4:24pm
Hello,
I have installed OpusFSI a few days ago and with the help of Stephen got it running. I use only the weather part in my 737 cockpit (with P3D3.3 and Prosim) and am very satisfied with the quality of the weather. Much better than Active Sky which I used for 2 years.
The program starts without problem, connects to P3D, loads Metars etc, creates weather and injects it in the sim. But for some mysterious reason after, say 20 minutes, it stops and is gone without an error announced. The spy window disappears at the same time, so cannot see what is going wrong. I only use OpusFSI on my server. The Opus map is shared with everyone, the virus scanner and windows is turned off and the UAC also. So what is causing the crash? Any ideas??
Help would be much appreciated.

Fedor
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 12642
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: March-17-2017 at 4:34pm
Hi Fedor,

Very strange, I will give it some thought. Do you have a stable internet connection? Perhaps it is shutting down during the next weather update. Do you have Win Defender active? Have you allowed P3DSERVER on private and public networks? I will set up an extended test here over the weekend and give it some thought. This sort of thing is usually windows or some other application shutting it down during a weather update when it's requesting METAR data over the Internet. But I will check the licensing checks to make sure nothing could be causing problems. I have no other reported problems.

I will report back if I think of anything over this weekend. In the meantime check your setup against the Getting Started Guide and double check all AV, Win Defender, UAC, etc. are shut down. I know Win Defender can re enable itself automatically after some time on Win 10 when it becomes a full fledged anti virus.

Stephen :-)
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 12642
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: March-17-2017 at 4:39pm
It won't be a crash otherwise an error message would appear. So it's most likely either the program failing some periodic licence or validity check, or Win Defender waking up and aborting the program when it next tries to access the Internet.

I will double check all the periodic validity checking at my end. Perhaps you could see about completely disabling Win Defender to stop it auto starting, and check through the GS Guide to make sure all is as it should be,

Have you installed in c:\OpusFSI_v5 folder?

We should be able to get to the bottom of this.

Stephen :-)
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 12642
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: March-17-2017 at 4:45pm
Another thing that would cause it to abort would be receiving a Sim Exit event through SimConnect, it would think the sim has shut down so it aborts. I will investigate.

If it's to do with a weather update you could monitor Spy and even force an update after say 15 minutes.

Stephen :-)
Back to Top
fedorklootwijk View Drop Down
New Member
New Member


Joined: March-01-2015
Location: Netherlands
Points: 18
Post Options Post Options   Thanks (0) Thanks(0)   Quote fedorklootwijk Quote  Post ReplyReply Direct Link To This Post Posted: March-17-2017 at 5:10pm
I will double check everything according to your advices. Unfortunately I'm away for the weekend, so it will be on monday.
Regards,

Fedor
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 12642
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: March-18-2017 at 2:09am
What options in the Weather dialog were you using? For example, did you have the Import METARs From Data File option set perhaps without using a GLOB metar ?

I mention this because I am working on this scenario.

Stephen
Back to Top
fedorklootwijk View Drop Down
New Member
New Member


Joined: March-01-2015
Location: Netherlands
Points: 18
Post Options Post Options   Thanks (0) Thanks(0)   Quote fedorklootwijk Quote  Post ReplyReply Direct Link To This Post Posted: March-18-2017 at 2:32am
No, I only had the actual, live, weather.

Fedor
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 12642
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: March-18-2017 at 2:37am
Next time you could try opening the Spy window and forcing a weather update via the addon menu or weather dialog. You can then watch the weather update in Spy as it downloads and generates the new weather.

I will investigate possible causes over this weekend. I take it your FSISERVER.log file doesn't report any licence check problems. You could email me the log file for me to check.

Stephen

opusfsi@opussoftware.co.uk
Back to Top
fedorklootwijk View Drop Down
New Member
New Member


Joined: March-01-2015
Location: Netherlands
Points: 18
Post Options Post Options   Thanks (0) Thanks(0)   Quote fedorklootwijk Quote  Post ReplyReply Direct Link To This Post Posted: March-19-2017 at 4:39am
Last night I tried another short flight (EHAM EGMC) and the OpusFSI server stopped twice without any obvious reason.
Windows defender was permanently off
No other anti-virus software active
OpusFSI_v5 and P3D maps shared with "everyone"
internet by a LAN connection
Only Live weather active
OpusFSI menu visible in addon menu of P3D
No errors in the log file (see JPG attachment)
Metars downloaded and weather generated (beautifull yesterday, by the way)
Manual updating looks normal in the Spy window



Hope you can help me.
Fedor
Back to Top
fedorklootwijk View Drop Down
New Member
New Member


Joined: March-01-2015
Location: Netherlands
Points: 18
Post Options Post Options   Thanks (0) Thanks(0)   Quote fedorklootwijk Quote  Post ReplyReply Direct Link To This Post Posted: March-19-2017 at 4:43am
Here are the log files.
Fedor
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 12642
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: March-19-2017 at 4:57am
Is that all you have in the FSISERVER.log file?

If it stopped without reason and not when you were doing anything or requesting anything in particular (e.g. Opening an LWA Map, updating the weather etc.) it could be either a periodic check failing or an unsolicited exit event via SimConnect received. I will investigate this end and try to see if I can determine.

Stephen :-)
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 12642
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: March-19-2017 at 5:17am
OK, I've confirmed the log file format. There should be some other info logged but its also missing on mine so I will see about correcting that.
 
I am testing and trying to recreate something similar or identify possible shutdown events and record them. I will let you know of my progress here.
 
Stephen :-)
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 12642
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: March-20-2017 at 7:05am
I still think this could be down to SimConnect incompatibilities. You could try installing the Microsoft SimConnect and running the server as FSISERVER P3D2. This will then run in P3D version 2 mode using the DotNet 2 SimConnect.

I am seeing if I can log the reason for a shutdown in the FSISERVER.log file. For example, SimConnect Exit, SimConnect Disconnect, etc.

Stephen
Back to Top
fedorklootwijk View Drop Down
New Member
New Member


Joined: March-01-2015
Location: Netherlands
Points: 18
Post Options Post Options   Thanks (0) Thanks(0)   Quote fedorklootwijk Quote  Post ReplyReply Direct Link To This Post Posted: March-20-2017 at 8:51am
What if I upgrade my P3D 3.3 to 3.4? Could that solve the simconnect problem?

Fedor
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 12642
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: March-20-2017 at 9:04am
Yes.
Back to Top
fedorklootwijk View Drop Down
New Member
New Member


Joined: March-01-2015
Location: Netherlands
Points: 18
Post Options Post Options   Thanks (0) Thanks(0)   Quote fedorklootwijk Quote  Post ReplyReply Direct Link To This Post Posted: March-20-2017 at 12:29pm
Upgraded to P3D 3.4. Copied the simconnect dll ( from the SDK 3.4) to OpusFSI_vs5 map. Rechecked the anti virus software off. The problem stays the same. Everything works as it should, but after 10-15 minutes the OpusFSI progam shuts down.

Fedor
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 12642
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: March-20-2017 at 12:48pm
No need to copy the SimConnect dll, you should simply revert back to the DLL I supplied.

Sounds like you could have a licence checking error somewhere, most likely a problem checking one of the files, or still some program shutting it down.

I will see if I can add some sort of detection and post a new beta. Yours is the only system doing this. I had mine running all day long. So it's something occurring on your system. Just have to identify what.

Are you certain you have shutdown the AV and Win Defender? Not just tried to trust the folder or programs. Win Defender will re enable itself automatically if not shutdown.

Stephen
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 12642
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: March-20-2017 at 1:10pm
I assume you have it running in UNLIMITED MODE. If you search for Win Defender does Windows report it is shutdown?

What weather update period do you have set within the Weather Downloads dialog.

Stephen
Back to Top
fedorklootwijk View Drop Down
New Member
New Member


Joined: March-01-2015
Location: Netherlands
Points: 18
Post Options Post Options   Thanks (0) Thanks(0)   Quote fedorklootwijk Quote  Post ReplyReply Direct Link To This Post Posted: March-20-2017 at 5:18pm
Reinstalled the lockheedmartinsimconnect.dll of the OpusFSI package
Double checked windows defender and AV software off
Running in unlimited mode
Windows defender report is empty
Weather update period is default (60 min, 160km)

Problem stays the same

Fedor
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 12642
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: March-20-2017 at 8:48pm
Thanks,

Have you removed all Launch statements for the as_btstrp.DLL from within the sims AppData DLL.XML file?

I will have another look at the software to double check there are no internal checks that could cause this. Have you tried flying in windowed mode with Spy open to see what OpusFSI is doing when it aborts. Most likely a weather update in which case check your DLL.XML if you've ever had AS installed.

Please note, each time you run AS it will enable the Launch of its bootstrap dll (as_btstrp.dll) within the sims DLL.XML file.

Stephen
Back to Top
fedorklootwijk View Drop Down
New Member
New Member


Joined: March-01-2015
Location: Netherlands
Points: 18
Post Options Post Options   Thanks (0) Thanks(0)   Quote fedorklootwijk Quote  Post ReplyReply Direct Link To This Post Posted: March-21-2017 at 7:09am
I have removed all AS launch statements (yes, they were there) but it made no difference.
I'll check the spy window during the flight and report back

Fedor
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 12642
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: March-21-2017 at 12:19pm
Many thanks Fedor, I will try and get a new beta posted for you to try soon and hopefully log any known reason for a shutdown.

Stephen :-)
Back to Top
njflyer View Drop Down
New Member
New Member


Joined: March-10-2010
Points: 18
Post Options Post Options   Thanks (0) Thanks(0)   Quote njflyer Quote  Post ReplyReply Direct Link To This Post Posted: March-26-2017 at 6:36pm
Hi Stephen,
I am having the same problem actually. I do not use live weather and only the camera portion of the product.
Thank you!
Back to Top
Opus Software View Drop Down
Senior Member
Senior Member


Joined: April-12-2012
Location: Grantham, UK
Points: 12642
Post Options Post Options   Thanks (0) Thanks(0)   Quote Opus Software Quote  Post ReplyReply Direct Link To This Post Posted: March-27-2017 at 2:44am
Thanks for the heads up, I will start testing with just Live Camera and see what could be the cause. I am back in the office in a few days time and will announce here when I have a new beta for you to try.

Stephen :-)
Back to Top
njflyer View Drop Down
New Member
New Member


Joined: March-10-2010
Points: 18
Post Options Post Options   Thanks (0) Thanks(0)   Quote njflyer Quote  Post ReplyReply Direct Link To This Post Posted: March-27-2017 at 4:43pm
Thank you very much Stephen, let me know if you need me to run any tests. The FSISERVER.log was as follows after the latest crash:

OpusFSI Flight Simulator Interface

Log Generated Monday, March 26, 2017, 4:18 PM Hrs 

Installed Folder: C:\OPUSFSI_V5

FSICONFIG Sim Folder: D:\Program Files (x86)\Lockheed Martin\Prepar3D v3
FSICONFIG Sim Folder: OK
FSIGENCOM Initialise: OK

Data Download ...
Data Download Initiated
Data Download Ready
Data Download Completed
Data Download Checked
Data Download Validated

Invoking DLL Checks ...

No DLL Errors Detected.

Installed Files:

P3DSERVER.EXE Version: 5.0.0.9  , Friday, March 10, 2017, 12:21 PM Hrs 
FSXSERVER.EXE Version: 5.0.0.9  , Friday, March 10, 2017, 12:21 PM Hrs 
FSDECODER.EXE Version: 5.0.0.9  , Friday, March 10, 2017, 12:21 PM Hrs 
FSISYSTEM.DLL Version: 5.0.0.9  , Friday, March 10, 2017, 12:21 PM Hrs 
OPUSFSI.DLL   Version: 5.0.0.9  , Friday, March 10, 2017, 12:21 PM Hrs 
OPUS.DLL      Version: Correct  , Monday, October 29, 2012, 6:24 PM Hrs 
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.02
Copyright ©2001-2015 Web Wiz Ltd.

This page was generated in 0.094 seconds.