SimForums.com Homepage
Forum Home Forum Home > General Discussion Forums > Flight Simulator General Discussion
  New Posts New Posts RSS Feed - Saitek Switch Panel Problems - WEIRD
  FAQ FAQ  Forum Search   Register Register  Login Login

Saitek Switch Panel Problems - WEIRD

 Post Reply Post Reply
Author
Message
JayKoit View Drop Down
New Member
New Member


Joined: July-20-2011
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote JayKoit Quote  Post ReplyReply Direct Link To This Post Topic: Saitek Switch Panel Problems - WEIRD
    Posted: August-02-2011 at 9:05pm

Hello Everyone,


So i just built a new FSX computer with Windows 7 64. I installed new updated drivers for all my Saitek gear (Multi Panel, Switch Panel, Radio Panel, Throttle Quadrant) and everythings working well, except my switch panel.


It works fine on the test page, everything doing what its supposed to, but when I load a flight, its like the wires literally get crossed inside the thing!  The Engine Start knob turns the avionics on and off, The Avionics switch turns Master on/off, fuel pump works about half the time, usually have to flip it 2-3X just to get it to switch on or off. And only half of the light switches work, panel lights will flash for a millisecond, but not stay on.


I have redownloaded and reinstalled drivers several times, moved the switch panel to various WORKING usb ports directly on the computer (NO hubs at all) and tried launching the plugin manually from the Saitek folder.


Any Thoughts?


I'm running FSX Acceleration SP2 with GEX, REX, UTX, and FSG, FS Flying School 2010, .  My system specs are:


AMD Phenom II 955 OC'D to 3.4GHZ

Asus m4a785T mobo

xfx Radeon 6790 OC'd to 875/1100

Windows 7 HP 64bit

4gb G Skill DDR2 800 dual channel

WD Caviar Black 640 GB 

Apevia 700w PSU




Thanks!

Jason
Comp: AMD Ph. II 955 @3.4ghz, asus m4a785T, 4GB G.Skill DDR2, XFX Radeon HD 6790 GPU. OS: W7 64bit. Software: FSX Accel. SP2, FSGen., Megascenery HI, LV, Reno
Back to Top
Phase View Drop Down
Senior Member
Senior Member


Joined: October-15-2004
Location: Antipodes
Points: 1563
Post Options Post Options   Thanks (0) Thanks(0)   Quote Phase Quote  Post ReplyReply Direct Link To This Post Posted: August-03-2011 at 5:58pm
Jason
Are you running the Saitek SST software (not the drivers)?  If yes, try disabling it and just assign the various functions in FSX
Duplicate assignements of buttons keys axes - FSX is sneaky even check the mouse!
Just a couple of thoughts.
PeterH
Nil illegitimum carborundum est

FSX SP2; i7 2600K, OC 5THz liq N2 cooling 16GB 1600 DDR3 RAM, GTX670, WINDOWS 7 64; 256GB OCZ Vertex SSD; Samsung 2233RZ 120Hz Monitor
Back to Top
JayKoit View Drop Down
New Member
New Member


Joined: July-20-2011
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote JayKoit Quote  Post ReplyReply Direct Link To This Post Posted: August-03-2011 at 7:39pm
Hello again PeterH, thanks for the reply.

I'm not running the SST software, but I actually just got a fix from another forum that I wanted to share:

When I downloaded the drivers from saitek for windows 7 64 bit, they came in a bundle. That bundle installs both the saipanels.exe AND saipanelsfs9.exe (for FS2004), so when I launched FSX it launched both fsx and fs9 drivers simultaneously, (or at least I can reasonably assume it did), causing the erratic behavior in my switch panel.

So I simply moved the fs9 driver to a new folder on my desktop, and all is well.

I also wanted to share that I received other replies (on another forum) from users who switched from the saitek drivers to SPAD drivers with great success. 

Jason
Comp: AMD Ph. II 955 @3.4ghz, asus m4a785T, 4GB G.Skill DDR2, XFX Radeon HD 6790 GPU. OS: W7 64bit. Software: FSX Accel. SP2, FSGen., Megascenery HI, LV, Reno
Back to Top
Phase View Drop Down
Senior Member
Senior Member


Joined: October-15-2004
Location: Antipodes
Points: 1563
Post Options Post Options   Thanks (0) Thanks(0)   Quote Phase Quote  Post ReplyReply Direct Link To This Post Posted: August-03-2011 at 9:15pm
Jason
Great news and a good fix!
PeterH
Nil illegitimum carborundum est

FSX SP2; i7 2600K, OC 5THz liq N2 cooling 16GB 1600 DDR3 RAM, GTX670, WINDOWS 7 64; 256GB OCZ Vertex SSD; Samsung 2233RZ 120Hz Monitor
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 10.14
Copyright ©2001-2012 Web Wiz Ltd.

This page was generated in 0.156 seconds.