SimForums.com Homepage
Forum Home Forum Home > Flight One Software Forums > Scenery and Mission Making Tools
  New Posts New Posts RSS Feed - Instant Oject Studio  objects are invisible
  FAQ FAQ  Forum Search   Register Register  Login Login

Instant Oject Studio objects are invisible

 Post Reply Post Reply
Author
Message
hendrik357 View Drop Down
Intermediate Group
Intermediate Group


Joined: January-18-2014
Location: WA
Points: 73
Post Options Post Options   Thanks (0) Thanks(0)   Quote hendrik357 Quote  Post ReplyReply Direct Link To This Post Topic: Instant Oject Studio objects are invisible
    Posted: December-26-2016 at 2:36pm
I have made a number of objects with Instant Object Studio and on the computer I created them on they show and work just fine. I use these objects for FSX.

The problem: When I transfer the object files to another computer and add them to FSX they will show up in the object list But when I add them to scenery I am building they are invisible.

I use Instant Scenery for adding objects.

Thanks for a place to share such issues.

                                  Dan Culver
hendrik357
Back to Top
ualani View Drop Down
Senior Member
Senior Member


Joined: March-30-2011
Points: 218
Post Options Post Options   Thanks (0) Thanks(0)   Quote ualani Quote  Post ReplyReply Direct Link To This Post Posted: January-11-2017 at 8:31am
Try changing the GUID's and see if they show up on the second computer.
Back to Top
hendrik357 View Drop Down
Intermediate Group
Intermediate Group


Joined: January-18-2014
Location: WA
Points: 73
Post Options Post Options   Thanks (0) Thanks(0)   Quote hendrik357 Quote  Post ReplyReply Direct Link To This Post Posted: January-11-2017 at 12:55pm
how do I change the GUID?
hendrik357
Back to Top
ualani View Drop Down
Senior Member
Senior Member


Joined: March-30-2011
Points: 218
Post Options Post Options   Thanks (0) Thanks(0)   Quote ualani Quote  Post ReplyReply Direct Link To This Post Posted: January-12-2017 at 10:40am
Let me first ask, what do you use to add your models into a library. (Create the bgl's.) 
Back to Top
FSDiscoverer View Drop Down
Moderator Group
Moderator Group


Joined: November-17-2006
Points: 3641
Post Options Post Options   Thanks (0) Thanks(0)   Quote FSDiscoverer Quote  Post ReplyReply Direct Link To This Post Posted: January-12-2017 at 2:37pm
Do objects show up when you add them with IS3 (and move them with the mouse) and then disappear after you restart FSX, or do they not appear at all?

Did you also copy object textures? If textures are missing, the objects might not show up in the 3D view.

If you add some stock objects to the same scenery file you are building, do they show up?

Back to Top
hendrik357 View Drop Down
Intermediate Group
Intermediate Group


Joined: January-18-2014
Location: WA
Points: 73
Post Options Post Options   Thanks (0) Thanks(0)   Quote hendrik357 Quote  Post ReplyReply Direct Link To This Post Posted: January-12-2017 at 7:59pm
I use the the Instant Object Studio program to build the object and the object is saved to the addon scenery folder along with texture files being saved to the addon scenery texture folder.

The objects will show up in Instant Scenery and I can add them to scenery but they are invisible. I do copy the textures but the objects are invisible.

The stock objects do show up.
hendrik357
Back to Top
FSDiscoverer View Drop Down
Moderator Group
Moderator Group


Joined: November-17-2006
Points: 3641
Post Options Post Options   Thanks (0) Thanks(0)   Quote FSDiscoverer Quote  Post ReplyReply Direct Link To This Post Posted: January-13-2017 at 8:28am
Quote The objects will show up in Instant Scenery and I can add them to scenery but they are invisible

So what do you see when you move the object in Instant Scenery with the mouse before adding it? Do you just see an empty mouse pointer, or does the object briefly show up in the 3D view and move with the mouse pointer, and then disappear after you added it?

Back to Top
ualani View Drop Down
Senior Member
Senior Member


Joined: March-30-2011
Points: 218
Post Options Post Options   Thanks (0) Thanks(0)   Quote ualani Quote  Post ReplyReply Direct Link To This Post Posted: January-13-2017 at 12:08pm
Hendrick,
Send me a PM and I'll see if I can better help you one on one.
Back to Top
hendrik357 View Drop Down
Intermediate Group
Intermediate Group


Joined: January-18-2014
Location: WA
Points: 73
Post Options Post Options   Thanks (0) Thanks(0)   Quote hendrik357 Quote  Post ReplyReply Direct Link To This Post Posted: January-13-2017 at 9:09pm
I just see an empty mouse pointer. The object is invisible.

Thanks for the help and ideas. I will give you a pm but cant get to it till maybe later tomorrow.
hendrik357
Back to Top
FSDiscoverer View Drop Down
Moderator Group
Moderator Group


Joined: November-17-2006
Points: 3641
Post Options Post Options   Thanks (0) Thanks(0)   Quote FSDiscoverer Quote  Post ReplyReply Direct Link To This Post Posted: January-14-2017 at 5:54pm
This is quite strange.

Could you please email me the files you copied to the 2nd PC (the library BGL and the textures)?

Please mail them to: support@fsdiscover.com

I'll check if they work for me and if anything important is missing. Since you are able to add  stock objects, it cannot be a malfunction of IS3.
Back to Top
hendrik357 View Drop Down
Intermediate Group
Intermediate Group


Joined: January-18-2014
Location: WA
Points: 73
Post Options Post Options   Thanks (0) Thanks(0)   Quote hendrik357 Quote  Post ReplyReply Direct Link To This Post Posted: January-15-2017 at 3:27pm
I have sent you an eamil with a file and a screen shot. I can send others if needed.
hendrik357
Back to Top
FSDiscoverer View Drop Down
Moderator Group
Moderator Group


Joined: November-17-2006
Points: 3641
Post Options Post Options   Thanks (0) Thanks(0)   Quote FSDiscoverer Quote  Post ReplyReply Direct Link To This Post Posted: January-15-2017 at 3:39pm
I got your file.

It is missing a texture called "headrfame2 wood texture.bmp"

If I try adding the object without this texture, I get exactly the same result as in the screenshot you sent me.

After I added a texture called "headrfame2 wood texture.bmp" and restarted FSX, the object appeared correctly.

Note that the texture name your object uses had a typo in it - it begins with "headrfame2", not "headframe2". Maybe this typo is the reason why you didn't notice the missing texture on the 2nd PC.

Back to Top
hendrik357 View Drop Down
Intermediate Group
Intermediate Group


Joined: January-18-2014
Location: WA
Points: 73
Post Options Post Options   Thanks (0) Thanks(0)   Quote hendrik357 Quote  Post ReplyReply Direct Link To This Post Posted: January-15-2017 at 4:05pm
I have over come this problem. I created a new scenery folder and added it to the scenery library. All of the objects I created with IOS show up. I have a file the one I sent toyou in an email does show but still only in small pieces.

I have a couple of other issues relating to objects disappearing but will post those in a day or two.
hendrik357
Back to Top
hendrik357 View Drop Down
Intermediate Group
Intermediate Group


Joined: January-18-2014
Location: WA
Points: 73
Post Options Post Options   Thanks (0) Thanks(0)   Quote hendrik357 Quote  Post ReplyReply Direct Link To This Post Posted: January-15-2017 at 4:07pm
Ok In will look inot that and get back to you. Thanks for the help.
hendrik357
Back to Top
hendrik357 View Drop Down
Intermediate Group
Intermediate Group


Joined: January-18-2014
Location: WA
Points: 73
Post Options Post Options   Thanks (0) Thanks(0)   Quote hendrik357 Quote  Post ReplyReply Direct Link To This Post Posted: January-15-2017 at 4:21pm
Ok I did find the typeo. I renamed the file to headframe2 wood texture.bmp but the result is still the same. Do I have to go back to IOS and make the change there?

hendrik357
Back to Top
hendrik357 View Drop Down
Intermediate Group
Intermediate Group


Joined: January-18-2014
Location: WA
Points: 73
Post Options Post Options   Thanks (0) Thanks(0)   Quote hendrik357 Quote  Post ReplyReply Direct Link To This Post Posted: 11 hours 42 minutes ago at 2:15pm
I got it figured out at least partially. I took the headrfame2 texture file and put it in the main texture folder for FSX and it shows up as it should.

Something is not right with my addon scenery folder which is why that file wouldn't show up as it should have until I moved it to a different texture folder.
hendrik357
Back to Top
ualani View Drop Down
Senior Member
Senior Member


Joined: March-30-2011
Points: 218
Post Options Post Options   Thanks (0) Thanks(0)   Quote ualani Quote  Post ReplyReply Direct Link To This Post Posted: 10 hours 43 minutes ago at 3:14pm
By moving it to the main texture folder causes it to show now means that the same texture exists elsewhere in your FS setup. Do a system search and see if you can find it, probably in another library. There may be even more than one of them hiding somewhere else. When you find it, move it to somewhere out of FSX for safe keeping for now. Now put the headrfame2 texture that you moved to your main texture folder back to where you got it from (where it was just before you moved it to the main texture folder) and see if it shows up when you place the object.
Back to Top
hendrik357 View Drop Down
Intermediate Group
Intermediate Group


Joined: January-18-2014
Location: WA
Points: 73
Post Options Post Options   Thanks (0) Thanks(0)   Quote hendrik357 Quote  Post ReplyReply Direct Link To This Post Posted: 10 hours 23 minutes ago at 3:34pm
ok I will do as you have suggested. I will get back to you
hendrik357
Back to Top
hendrik357 View Drop Down
Intermediate Group
Intermediate Group


Joined: January-18-2014
Location: WA
Points: 73
Post Options Post Options   Thanks (0) Thanks(0)   Quote hendrik357 Quote  Post ReplyReply Direct Link To This Post Posted: 9 hours 48 minutes ago at 4:09pm
I performed a system check and didn't find any other copies of that file in FSX. I also placed it back into the original folder I had it in and the object did,t show up except small parts of it.

Then I placed it back in the main Texture folder of FSX and it showed up as it should.
hendrik357
Back to Top
FSDiscoverer View Drop Down
Moderator Group
Moderator Group


Joined: November-17-2006
Points: 3641
Post Options Post Options   Thanks (0) Thanks(0)   Quote FSDiscoverer Quote  Post ReplyReply Direct Link To This Post Posted: 4 hours 21 minutes ago at 9:36pm
Could it be that you placed a copy of the model library into the main scenery folder? So that you have a duplicate BGL file?

If this is the case, FSX will probably use the BGL file from the main scenery folder, which means it will also only look for textures in the main texture folder.

Back to Top
hendrik357 View Drop Down
Intermediate Group
Intermediate Group


Joined: January-18-2014
Location: WA
Points: 73
Post Options Post Options   Thanks (0) Thanks(0)   Quote hendrik357 Quote  Post ReplyReply Direct Link To This Post Posted: 4 hours 7 minutes ago at 9:50pm
I checked the main scenery fold and there is no duplicate BGL there, As far as I can tell there is only the one that I put in the main texture folder that works. I can.t find any duplicates in FSX.

I will check again tomorrow and get back to you as it is getting late evening here.
hendrik357
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.02
Copyright ©2001-2015 Web Wiz Ltd.

This page was generated in 0.157 seconds.