SimForums.com Homepage
Forum Home Forum Home > General Discussion Forums > Flight Simulator General Discussion
  New Posts New Posts RSS Feed - FSX CONFIG Advice :)
  FAQ FAQ  Forum Search   Register Register  Login Login

FSX CONFIG Advice :)

 Post Reply Post Reply
Author
Message
aceridgey View Drop Down
Senior Member
Senior Member


Joined: February-28-2010
Location: United Kingdom
Points: 115
Post Options Post Options   Thanks (0) Thanks(0)   Quote aceridgey Quote  Post ReplyReply Direct Link To This Post Topic: FSX CONFIG Advice :)
    Posted: August-01-2010 at 6:06pm
Hi guys :)

I am very confused about what settings to have in this config so they dont conflict, in particular texturemaxload, texturebandwidthmulti, fibreframefraction etc etc.

I would appricate GREATLY any advice and tips people give me! :)

[I also have a almost identical config file for locked fps = 30] monitor is 60hz...

All the best

[lots of sections cut out to save space]

[JOBSCHEDULER]
AffinityMask=14

[BufferPools]
UsePools=1
RejectThreshold=50000
PoolSize=2097152

[FSDREAMTEAM]
AntiPopUp=100
AltitudeCull=1

[Display]
ActiveWindowTitleBackGroundColor=0,28,140,64
ActiveWindowTitleTextColor=255,255,255
BLOOM_EFFECTS=0
ChangeTime=4.000000
InfoBrakesEnable=True
InfoLowerLeftBackGroundColor=255,0,0,128
InfoLowerLeftTextColor=255,255,255
InfoLowerRightBackGroundColor=255,0,0,128
InfoLowerRightTextColor=255,255,255
InfoOverspeedEnable=True
InfoParkingBrakesEnable=True
InfoPauseEnable=True
InfoSlewEnable=True
InfoStallEnable=True
InfoUpperRightBackGroundColor=0,0,0,0
InfoUpperRightTextColor=255,0,0
NonActiveWindowTitleBackGroundColor=24,33,87,64
NonActiveWindowTitleTextColor=255,255,255
SKINNED_ANIMATIONS=1
TextureMaxLoad=9
TEXTURE_BANDWIDTH_MULT=400
TransitionTime=4.000000
UPPER_FRAMERATE_LIMIT=0
WideViewAspect=False

[DISPLAY.Device.NVIDIA GeForce GTX 480.0]
AntiAlias=1
Mode=1680x1050x32
TriLinear=1

[GRAPHICS]
ALLOW_SHADER_30=1
SHADER_CACHE_VERSION=9872430
AC_SELF_SHADOW=0
AIRCRAFT_REFLECTIONS=1
AIRCRAFT_SHADOWS=0
COCKPIT_HIGH_LOD=1
D3D10=0
EFFECTS_QUALITY=2
GROUND_SHADOWS=0
HIGHMEMFIX=1
IMAGE_QUALITY=0
LANDING_LIGHTS=1
NUM_LIGHTS=8
See_Self=1
SHADER_CACHE_PRIMED=1693458478
SHADER_CACHE_PRIMED_10=1693458478
STALE_BUFFER_THRESHOLD=2147483647
TEXTURE_MAX_LOAD=4096
TEXTURE_QUALITY=3
Text_Scroll=1
ForceFullScreenVSync=1

[Main]
HideMenuFullscreen=1
HideMenuNormal=0
Location=172,0,1558,967,\\.\DISPLAY1
Maximized=1
PerfBucket=7
ProcSpeed=14160
SimObjectPaths.0=SimObjects\Airplanes
SimObjectPaths.1=SimObjects\Rotorcraft
SimObjectPaths.2=SimObjects\GroundVehicles
SimObjectPaths.3=SimObjects\Boats
SimObjectPaths.4=SimObjects\Animals
SimObjectPaths.5=SimObjects\Misc
SimObjectPaths.6=SimObjects\IVAO_MTL
User Objects=Airplane, Helicopter
FIBER_FRAME_TIME_FRACTION=0.33

[REALISM]
AutoCoord=False
AutoTrim=False
CrashDetection=False
CrashTolerance=1.000000
CrashWithDyn=False
GEffect=False
General=1.000000
GyroDrift=False
GyroEffect=1.000000
ManualLights=True
PFactor=0.960000
RealMixture=True
StressDamage=False
Torque=0.960000
TrueAirspeed=False
UnlimitedFuel=False


[SCENERY]
DAWN_DUSK_SMOOTHING=1
IMAGE_COMPLEXITY=5
LENSFLARE=1
SmallPartRejectRadius=1


[SOUND]
AmbientUI=0
AmbientUIMusic=FSX01
AmbientUIMusicVolume=-6.000000
PrimaryDevice={DEF00000-9C6D-47ED-AAF1-4DDA8F2B5C03}
SOUND=1
SOUND_FADER1=0.500000
SOUND_FADER2=0.500000
SOUND_FADER3=0.500000
SOUND_FADER4=0.500000
SOUND_LOD=0
SOUND_QUALITY=2
UISound=1
VoiceDevice={DEF00002-9C6D-47ED-AAF1-4DDA8F2B5C03}


[TERRAIN]
AUTOGEN_DENSITY=0
DETAIL_TEXTURE=1
LOD_RADIUS=9.000000
MAX_ASYNC_BATCHING_JOBS=2
MIN_DETAIL_TEXTURE_LEVEL=21
MAX_DETAIL_TEXTURE_LEVEL=21
MESH_COMPLEXITY=100
MESH_RESOLUTION=23
TEXTURE_RESOLUTION=27
WATER_EFFECTS=4
SWAP_WAIT_TIMEOUT=10

Rastafari Worldwide. Musician playing Drums, Steel pan, Bass keys etc. Dreadlocked Rasta
Back to Top
luap View Drop Down
Certified Professional
Certified Professional


Joined: December-11-2003
Points: 7909
Post Options Post Options   Thanks (0) Thanks(0)   Quote luap Quote  Post ReplyReply Direct Link To This Post Posted: August-01-2010 at 8:05pm


Paul Scott Bartelt

The grass is always greener over the septic tank



Back to Top
Ulf B View Drop Down
Senior Member
Senior Member


Joined: August-16-2004
Points: 513
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ulf B Quote  Post ReplyReply Direct Link To This Post Posted: August-02-2010 at 5:35am

Do you have any specific problem that make you suspect that there is a conflict?

Several of the tweaks (BP, TBM etc) don't have consistent effect across different systems. You have to test numerous of combinations to find the one that gives the best result on your system and how you use FSX.
 
I've made some tests over time and have settled down with just a few tweaks that work OK on my system:
TBM = 80
PoolSize= 100000000
 
AffinityMask and SmallPartRejectRadius have no effect on my system, so I don't use them.
As far as I remember the SmallPartRejectRadius setting hade some effect in FSX RTM and SP1, but not much effect in SP2.
You may remove the FIBER_FRAME_TIME_FRACTION setting since it's set to the default value.
 
 
 
Ulf B
Asus Z87-EXPERT, i7 4770K @4.5Ghz, 16GB Corsair Vengance 2400MHz
EVGA GTX 780
2x Intel 520-serien 240GB SSD, 4x 2TB WD HDD
Win7 Pro
Back to Top
Phase View Drop Down
Senior Member
Senior Member


Joined: October-15-2004
Location: Antipodes
Points: 1564
Post Options Post Options   Thanks (0) Thanks(0)   Quote Phase Quote  Post ReplyReply Direct Link To This Post Posted: August-02-2010 at 8:30pm
Ace
A couple of points:
STALE_BUFFER_THRESHOLD=2147483647
I thought that the max value here should be 1024 -Hey-Sus changed this in his AVSIM cfg tweaks post?QuestionSmile
 
ForceFullScreenVSync=1
I thought that this was only relevant to ATI cards - although to be fair Hey-Sus he posts that it works with nvidia cards??Question  I would take Nick's advice on this one.Wink
Regards
PeterH
Nil illegitimum carborundum est

FSX SP2; i7 2600K, OC 5THz liq N2 cooling 16GB 1600 DDR3 RAM, GTX670, WINDOWS 7 64; 256GB OCZ Vertex SSD; Samsung 2233RZ 120Hz Monitor
Back to Top
NickN View Drop Down
Certified Professional
Certified Professional


Joined: November-21-2007
Points: 13891
Post Options Post Options   Thanks (0) Thanks(0)   Quote NickN Quote  Post ReplyReply Direct Link To This Post Posted: August-02-2010 at 8:36pm
 
 
SmallPartRejectRadius is useless in FSX Sp1-SP2 and SWAP_WAIT_TIMEOUT was also changed with SP2 according to PTaylor. leave them out of the config
 
TEXTURE_BANDWIDTH_MULT=400   rediculous!  40-120  and there can be circumstances where lower values are better but most common will be somewhere between the default of 40 and 120
 
TextureMaxLoad=9   LOL    thats the default and is really a crock to add/change if TBM (above) is set correctly 

FIBER_FRAME_TIME_FRACTION  useless on anything other than a single core proc --OR-- unless photoscenery or tile proxy is in use (even with multicore),.. and even then it would not be set to 33
 
AntiAlias=1  means we are not using the better quality video settings that Nhancer or the workaround I provided allows.. no autogen or building shimmer issues?  OK then, this is fine
 
[BufferPools]
UsePools=1
RejectThreshold=50000
PoolSize=2097152
 
NONSENSE!   we dont use all those values
 
 [JOBSCHEDULER]
AffinityMask=14   do we really need this?  is it confirmed it really makes a TRUE difference? If so this is a good value
 
LOD_RADIUS=9.000000   9?   GOOD LUCK!
 

MAX_ASYNC_BATCHING_JOBS=2   PLEASE!
 
STALE_BUFFER_THRESHOLD=2147483647  Total nonsense value!
 
ALLOW_SHADER_30=1  on a Nvidia card? 
 
ForceFullScreenVSync=1  not needed with Nvidia athough it can be used, just extra junk in the config with Nvidia
 
 
this is a case where it appears someone is reading forums and loading their config with anything they find with no rhyme or reason to the use of the edits
 
 
 
 
 
Back to Top
steve_1979 View Drop Down
Senior Member
Senior Member


Joined: September-11-2008
Points: 352
Post Options Post Options   Thanks (0) Thanks(0)   Quote steve_1979 Quote  Post ReplyReply Direct Link To This Post Posted: August-03-2010 at 6:09am
Originally posted by aceridgey aceridgey wrote:

I would appricate GREATLY any advice and tips people give me!
 
Delete your current fsx.cfg (but keep a back up just in case).
 
Now when you restart FSX it will rebuild the original default fsx.cfg.
 
Next make only the changes to the fsx.cfg recomended here by NickN: www.simforums.com/forums/forum_posts.asp?TID=29041
 
BP=0 works for some people so is worth trying but be aware that it will probley cause problems or other side effects so be prepared to switch back if it doesn't work best for your PC/setup.
 
Hope this helps. Smile
Back to Top
paula View Drop Down
Senior Member
Senior Member


Joined: December-13-2009
Points: 605
Post Options Post Options   Thanks (0) Thanks(0)   Quote paula Quote  Post ReplyReply Direct Link To This Post Posted: August-03-2010 at 3:40pm
Nick,
 
regarding your answers to configuration I have a question regarding affinitymask 14.
If I change my cfg file to aff.14 my cores give above the netherlands 2000 
0=25
1=80
2=100
3=100
If I take this out the cfg I have
0=80
1=100
2=100
3=100
does it make any difference you think?
 
I have fsx accelerator and did a lot of trials regarding tweaking.
I discovered that with nvidia I could have a good picture but as soon as I went to IVAO
I got some troubles so I went back to nhancer and also to 197.45 driver.
 
Now I took away all the tweaks and nothing changes so most of them as you said
are useless.
There is only one who gives me a great improvement and that is
bufferpool but the one USEPOOLS=0
I got a great FPS
I use unlimited and the autogen to zero (exept the airports autogen) because I use a lot of addons
from germany and also GEX and UTX/ UK and mega california and so on
put TBM on 120 and left out timefraction and swaptime etc.
is this a reaseble set up?
 
doeke
 
 
paula
Back to Top
lumat View Drop Down
Intermediate Group
Intermediate Group


Joined: April-30-2009
Points: 78
Post Options Post Options   Thanks (0) Thanks(0)   Quote lumat Quote  Post ReplyReply Direct Link To This Post Posted: August-13-2010 at 8:53pm
Hello
 
Are you sure that FIBER_FRAME_TIME_FRACTION is totaly unless ?
 
I've tried some values for FIBER_FRAME_TIME_FRACTION. At parking (Aerosoft Paris CDG) with the PMDG J41 and without AI Traffic.
If I decrease this value, I notably increase the fps. I set finally it to 0.17 with a interesting gain.
I use GEX Europe. I don't use any photorealist sceneries.
 
Luc
 
 
 
Intel I72600K - 8Go RAM - Geforce GTX560Ti - Windows 7 64bits
Back to Top
NickN View Drop Down
Certified Professional
Certified Professional


Joined: November-21-2007
Points: 13891
Post Options Post Options   Thanks (0) Thanks(0)   Quote NickN Quote  Post ReplyReply Direct Link To This Post Posted: August-13-2010 at 8:55pm
 
If that value is change using textures and autogen,, its ROB PETER TO PAY PAUL   If you think reducing that value below the default wont cause blurs or other 'slow terrain loading' direct or distance issues, you are probably not looking out the window at low altitude or wouldn't know what clear and sharp scenery to the horizon looks like to begin with Wink 
 
 
It all comes down to what you find important..   the FPS with the payware plane, or the details around the aircraft 
 
 
I have never needed to mess with that value.. but I also use top shelf modern hardware and do not see blurs anywhere, including the horizon
Back to Top
NickN View Drop Down
Certified Professional
Certified Professional


Joined: November-21-2007
Points: 13891
Post Options Post Options   Thanks (0) Thanks(0)   Quote NickN Quote  Post ReplyReply Direct Link To This Post Posted: August-13-2010 at 9:30pm
Originally posted by paula paula wrote:

Nick,
 
regarding your answers to configuration I have a question regarding affinitymask 14.
If I change my cfg file to aff.14 my cores give above the netherlands 2000 
0=25
1=80
2=100
3=100
If I take this out the cfg I have
0=80
1=100
2=100
3=100
does it make any difference you think?
 
I have fsx accelerator and did a lot of trials regarding tweaking.
I discovered that with nvidia I could have a good picture but as soon as I went to IVAO
I got some troubles so I went back to nhancer and also to 197.45 driver.
 
Now I took away all the tweaks and nothing changes so most of them as you said
are useless.
There is only one who gives me a great improvement and that is
bufferpool but the one USEPOOLS=0
I got a great FPS
I use unlimited and the autogen to zero (exept the airports autogen) because I use a lot of addons
from germany and also GEX and UTX/ UK and mega california and so on
put TBM on 120 and left out timefraction and swaptime etc.
is this a reaseble set up?
 
doeke
 
 
 
 
 
 
 
 
as we discussed in another thread, http://www.simforums.com/forums/forum_posts.asp?TID=35784&PID=208299&title=loadtime-scenery-or-textures#208299  you are overheating your proc overclocking it to 3.7 using the Intel box heatsink and the memory you are using is slow.. 
 
get those 2 fixed and you will probably find your issues are resolved
Back to Top
lumat View Drop Down
Intermediate Group
Intermediate Group


Joined: April-30-2009
Points: 78
Post Options Post Options   Thanks (0) Thanks(0)   Quote lumat Quote  Post ReplyReply Direct Link To This Post Posted: August-14-2010 at 5:08am
Originally posted by NickN NickN wrote:

 
If that value is change using textures and autogen,, its ROB PETER TO PAY PAUL   If you think reducing that value below the default wont cause blurs or other 'slow terrain loading' direct or distance issues, you are probably not looking out the window at low altitude or wouldn't know what clear and sharp scenery to the horizon looks like to begin with Wink 
  
It all comes down to what you find important..   the FPS with the payware plane, or the details around the aircraft 
  
I have never needed to mess with that value.. but I also use top shelf modern hardware and do not see blurs anywhere, including the horizon
You're right, I know.
 
But yes I use some addon aircraft, heavy with fps.
 
I try to optimize my system for a correct framerate (Say about 20fps).
Actually (after read your advises on this forum too) the modifications on my FSX.CFG are :
 
[JOBSCHEDULER]
AffinityMask=14
 
[BUFFERPOOLS]
RejectThreshold=98304
 
[GRAPHICS]
HIGHMEMFIX=1
 
[Display]
TEXTURE_BANDWIDTH_MULT=40
UPPER_FRAMERATE_LIMIT=0 (I use FPS_Limiter set to 30)
 
[DISPLAY.Device.NVIDIA GeForce GTX 460.0]
Mode=1680x1050x32
TriLinear=1
 
My computer is
Q9550 OC to 3.9GHz
4Go RAM PC8500
Geforce GTX460 1Go OC to 750/1850/1500 
Windows 7 64
 
FSX is installed on a dedicated partition. No programs are running with windows (like Antivirus...)
 
My addons lanclass/textures : UTX europe, GEX Europe, REX2
 
Actually, with an addon like PMDG J41, I have 20-22 fps on the aerosoft Paris CDG and AES, without traffic (correct) 
but only 15-16 fps with UT2 set to 70% (Weekly) and 20% (Daily).
 
I search a way to increase this last value without decrease Ut2 , but is there one ? Confused
 
I removed FFTF to see, you're right, decrease FFTF is not a good solutionn ot very efficiency Wink
 
Have you any other advises ? Big smile
Intel I72600K - 8Go RAM - Geforce GTX560Ti - Windows 7 64bits
Back to Top
NickN View Drop Down
Certified Professional
Certified Professional


Joined: November-21-2007
Points: 13891
Post Options Post Options   Thanks (0) Thanks(0)   Quote NickN Quote  Post ReplyReply Direct Link To This Post Posted: August-14-2010 at 12:09pm
 
 
Your issue is hardware.. you are bottlenecking a GTX460 with old DDR2 CPU/Memory platform
 
On DDR2 the northbridge is on the motherboard and it reduces the efficency of the memory communication to the CPU by 50%!   Therefore, the video card is far faster than the CPU/memory subsystem can feed it and you are bottlenecked, regardless of the clock.
 
If you move to a modern i7 CPU and triple channel DDR3 system that removes the northbridge bottleneck, your issues would be resolved
 
Back to Top
lumat View Drop Down
Intermediate Group
Intermediate Group


Joined: April-30-2009
Points: 78
Post Options Post Options   Thanks (0) Thanks(0)   Quote lumat Quote  Post ReplyReply Direct Link To This Post Posted: August-15-2010 at 3:47am
Thank you very much Nick.
 
I see that OC my QuadCore is a good thing, but it's not sufficient. I know what I must to do now. As soon as possible I'll move to a I7.
 
Luc
Intel I72600K - 8Go RAM - Geforce GTX560Ti - Windows 7 64bits
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 10.14
Copyright ©2001-2012 Web Wiz Ltd.

This page was generated in 0.158 seconds.