SimForums.com Homepage
Forum Home Forum Home > Flight One Software Forums > Flight One Product Support
  New Posts New Posts RSS Feed - [Answered] Problems with GTN 750
  FAQ FAQ  Forum Search   Register Register  Login Login

[Answered] Problems with GTN 750

 Post Reply Post Reply
Author
Message
michaelsuede View Drop Down
New Member
New Member


Joined: April-17-2017
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote michaelsuede Quote  Post ReplyReply Direct Link To This Post Topic: [Answered] Problems with GTN 750
    Posted: April-17-2017 at 11:12pm
After installing a new graphics card, the GTN 750 no longer works.  I get a blank screen when the cockpit loads. I doubt the two are related, but it seems to have started after the new card install, so no idea why that may be.

I tried uninstalling the Garmin trainer (6211) and GTN (1.14) software and reinstalling.  However, after downloading and installing the latest trainer, now when Prepar3D v3 loads, I get an error message saying "Invalid GTN PC Trainer version... please go the sales website and download teh appropriate PC Trainer."

I find this error to be amusing because I'm using the version of the trainer that auto-downloaded when you open the Flight1 GTN installer application, from the Flight1 vendor site.

Any help would be appreciated.
Back to Top
Tiberiu View Drop Down
Senior Member
Senior Member


Joined: May-25-2002
Location: United States
Points: 5864
Post Options Post Options   Thanks (0) Thanks(0)   Quote Tiberiu Quote  Post ReplyReply Direct Link To This Post Posted: April-18-2017 at 2:41am
Hello,

Unfortunately V1.14 of the F1 GTN is old. We have now released V1.22, which supports the PC Trainer V6.21

Please go to the sales website of the F1 GTN, redownload the purchased file and reinstall using the key. You don't need to reinstall the PC Trainer V6.21, even though the installer will tell you to, because you have the latest.

By installing the latest F1 GTN, the GTN should work.
Back to Top
michaelsuede View Drop Down
New Member
New Member


Joined: April-17-2017
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote michaelsuede Quote  Post ReplyReply Direct Link To This Post Posted: April-18-2017 at 9:28pm
That did it.

Thanks for your help.
Back to Top
keokie View Drop Down
New Member
New Member


Joined: December-29-2016
Location: USA, Alaska
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote keokie Quote  Post ReplyReply Direct Link To This Post Posted: April-23-2017 at 12:56pm
Hello,

Can anyone direct me to where I should/can report this error I received?



Flight1 GTN Error Code: 20
Please contact support and provide this code: 2 and path C:\ProgramData\Garmin\GTN Trainer Data\DB\card2

thank you
Keokie
Back to Top
Tiberiu View Drop Down
Senior Member
Senior Member


Joined: May-25-2002
Location: United States
Points: 5864
Post Options Post Options   Thanks (0) Thanks(0)   Quote Tiberiu Quote  Post ReplyReply Direct Link To This Post Posted: April-23-2017 at 1:03pm
Keokie,

What version of the F1 GTN and GTN PC Trainer are you running?
Back to Top
keokie View Drop Down
New Member
New Member


Joined: December-29-2016
Location: USA, Alaska
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote keokie Quote  Post ReplyReply Direct Link To This Post Posted: April-23-2017 at 1:10pm
V1.22 on the GTN and I can not find the version date within the trainer.

I downloaded both versions today when I discovered the error.

I am in the wake of a recent Windows 10 automatic update and always anticipate these glitches.

Regards
Keokie
Back to Top
Tiberiu View Drop Down
Senior Member
Senior Member


Joined: May-25-2002
Location: United States
Points: 5864
Post Options Post Options   Thanks (0) Thanks(0)   Quote Tiberiu Quote  Post ReplyReply Direct Link To This Post Posted: April-23-2017 at 1:27pm
Please go here:
C:\ProgramData\Garmin\GTN Trainer Data\DB

There you will see some card files, make sure to keep just the "card" file and delete the "card2" to "card5" (whatever you have).

After that, copy the "card" file and rename it to "card2". This is it, it should work.
Back to Top
keokie View Drop Down
New Member
New Member


Joined: December-29-2016
Location: USA, Alaska
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote keokie Quote  Post ReplyReply Direct Link To This Post Posted: April-23-2017 at 1:51pm
Ok, I tried that, came up with original error code: 20, then an additional error code 20w and path C:\

Perhaps I should check to see if my video driver was updated also and roll back that driver?

Seems like when my Ati drivers update, my GTN 750 goes down, but never with an error code such as today.

I will let you know either way if it works. Help is much appreciated.

Thank you
Keokie
Back to Top
keokie View Drop Down
New Member
New Member


Joined: December-29-2016
Location: USA, Alaska
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote keokie Quote  Post ReplyReply Direct Link To This Post Posted: April-23-2017 at 9:49pm
No joy.

I tried a number of things. Including uninstalling and re installing the GTN trainer. Which wont even initialize after re-naming that file in (C:\ProgramData\Garmin\GTN Trainer Data\DB)

Flight1 will no longer allow me to download my copy of GTN750 either. looks like too many attempts. 

Any other ideas welcomed if you think of any. Until then, time to learn the G1000. I got spoiled using the 750.

I will reach out to Flight1 tmo when they are open.

Thanks again for the ideas. This sim community is a very good resource.

regards


Keokie
Back to Top
Tiberiu View Drop Down
Senior Member
Senior Member


Joined: May-25-2002
Location: United States
Points: 5864
Post Options Post Options   Thanks (0) Thanks(0)   Quote Tiberiu Quote  Post ReplyReply Direct Link To This Post Posted: April-24-2017 at 2:01am
Hello,

You must COPY and rename the file, not just copy it.
This means that your folder must have a "Card" file and a "card2" file.

You can reactivate your order automatically, by following the instructions here:
https://www.flight1.com/view.asp?page=kman

By the way, no need to reinstall the F1 GTN if it works and gives you that error message. Just make sure that the standalone GTN PC Trainer works fine and then come back to us.

Don't worry, we will get this problem fixed.
Back to Top
keokie View Drop Down
New Member
New Member


Joined: December-29-2016
Location: USA, Alaska
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote keokie Quote  Post ReplyReply Direct Link To This Post Posted: April-24-2017 at 4:33pm
Hello,

Yes, first off I made a copy of "card" it looked like this "card - copy" in the folder.

Next deleted "card2" and "card3"

Then Renamed "card" to "card2"

Kept "card - copy" in the folder.

Same issue in FSX:SE. When GTN 750 should initialize, the sim pauses. It will not run what ever I try.

Next I tried the Trainer, still nothing. Will not power on. I started getting these errors citing "direct X might not be supported by my video driver". I have the most up to date drivers installed now on my Radeon 480. Even the older drivers would not work.

I am ready to try what ever you recommend next. I'm certain we can figure it out.

Thank you for your time.


Keokie
Back to Top
Bert Pieke View Drop Down
Senior Member
Senior Member


Joined: January-03-2003
Location: Canada
Points: 4890
Post Options Post Options   Thanks (0) Thanks(0)   Quote Bert Pieke Quote  Post ReplyReply Direct Link To This Post Posted: April-24-2017 at 5:21pm
Try again..

You need "Card" and "Card2"

Suggest renaming your "Card - Copy" to "Card".
Bert
Back to Top
keokie View Drop Down
New Member
New Member


Joined: December-29-2016
Location: USA, Alaska
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote keokie Quote  Post ReplyReply Direct Link To This Post Posted: April-25-2017 at 2:34am
Tried that and it did not work.

I did a clean uninstall of my AMD video and restarted what must have been the default windows driver. The GTN Trainer worked.

So I then downloaded my last known working driver 17.2.1 (dated 2/12/2017) and back to not working.

I then downloaded the very latest from AMD and not working. The error that pops up now says something about Direct X? maybe a registry issue?



Keokie
Back to Top
Tiberiu View Drop Down
Senior Member
Senior Member


Joined: May-25-2002
Location: United States
Points: 5864
Post Options Post Options   Thanks (0) Thanks(0)   Quote Tiberiu Quote  Post ReplyReply Direct Link To This Post Posted: April-25-2017 at 6:34am
This is a known problem form AMD, it is their video card drivers.
We are in contact with AMD for a solution.
Please register for the official GTN support forum, which is located here, at simforums. There you will find a thread about it.

For now, you can resolve your problem by installing the AMD drivers version 16.12

Again, this is not us, it is AMDs fault and we are in contact with them for a solution, please understand this. We know how frustrating it is not to get the GTN working.
Back to Top
keokie View Drop Down
New Member
New Member


Joined: December-29-2016
Location: USA, Alaska
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote keokie Quote  Post ReplyReply Direct Link To This Post Posted: April-25-2017 at 5:26pm
Very happy to report 16.12.2 brought everything back to working again. Funny it worked with 17.2 for most of the winter, then nothing after the windows 10 update.

I do understand it is not a Flight1 issue and I hope it can be resolved in the future by AMD.

Thanks to everyone who helped. Like I said, this community is very helpful.

Much appreciated,
Keokie
Back to Top
iracer99 View Drop Down
New Member
New Member


Joined: April-29-2016
Location: California
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote iracer99 Quote  Post ReplyReply Direct Link To This Post Posted: May-20-2017 at 6:10am
Originally posted by keokie keokie wrote:

Very happy to report 16.12.2 brought everything back to working again. Funny it worked with 17.2 for most of the winter, then nothing after the windows 10 update.

I do understand it is not a Flight1 issue and I hope it can be resolved in the future by AMD.

Thanks to everyone who helped. Like I said, this community is very helpful.

Much appreciated,

Where did you find the AMD drivers version 16.12? AMD site only shows 17.4.4 and 17.5.2

I'm having the same problem. Has worked fine for about a year, now the blank screen. 
Back to Top
FlyingGasmask View Drop Down
New Member
New Member


Joined: July-22-2017
Location: Copenhagen
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote FlyingGasmask Quote  Post ReplyReply Direct Link To This Post Posted: February-07-2018 at 11:46am
Does anyone here know if this has been fixed with the newer versions of AMD software? I would like to update my graphics card. Confused
Back to Top
Bert Pieke View Drop Down
Senior Member
Senior Member


Joined: January-03-2003
Location: Canada
Points: 4890
Post Options Post Options   Thanks (0) Thanks(0)   Quote Bert Pieke Quote  Post ReplyReply Direct Link To This Post Posted: February-07-2018 at 11:55am
Originally posted by FlyingGasmask FlyingGasmask wrote:

Does anyone here know if this has been fixed with the newer versions of AMD software? I would like to update my graphics card. Confused


As best I know: Yes..
Bert
Back to Top
Tiberiu View Drop Down
Senior Member
Senior Member


Joined: May-25-2002
Location: United States
Points: 5864
Post Options Post Options   Thanks (0) Thanks(0)   Quote Tiberiu Quote  Post ReplyReply Direct Link To This Post Posted: February-08-2018 at 5:50am
Yes, just use the latest AMD drivers and you will be fine.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.10
Copyright ©2001-2017 Web Wiz Ltd.

This page was generated in 0.125 seconds.